Canadian Mac Forums at ehMac banner
1 - 11 of 11 Posts

·
Premium Member
Joined
·
9,103 Posts
Discussion Starter · #1 ·
......when you click "remember me" on a website.

I think the information somehow became corrupt because I now have to log in every time whereas before the log in happened automatically.
The window where you can tell the Mac to remember the User ID and password doesn't come up again since it already has that information (I assume), so how can I clear what may be corrupt information and reset this?
 

·
Premium Member
Joined
·
31,013 Posts
This has been an ongoing issue with certain browsers, certain sites and the latest OS.

Keychain stores the logins.

It's the reason I switched to Camino and Seamonkey stores properly as well.

Try Keychain repair.

Maybe Safari 3.0.3 fixes it but both Shiira and Safari have a similar erratic behaviour so the webkit is bust in some manner.

Total annoyance.
See if Camino 1.5 fixes it for you.
 

·
Premium Member
Joined
·
9,103 Posts
Discussion Starter · #3 ·
I have been using Camino 1.5 all along. That's where the problem might actually be.
I now wonder if things got screwed up when I was asked to download a beta of Camino 2.x to test a bug I was reporting.
I trashed, Camino 2.x after the test and downloaded Camino 1.5 again, but then had to log in on many sites manually the first time I visited them again.

The odd thing is that I only have the problem with two specific sites, ehMac and about two dozen other sites are fine.
I'm now trying both Safari and Firefox on the problem sites to see what that brings.

Running OS 10.4.8 with Camino 1.5, Firefox 2.0.0.4 and Safari 2.0.4.

I'll try keychain repair (if I find it), thanks.
 

·
Premium Member
Joined
·
9,103 Posts
Discussion Starter · #4 ·
Keychain verification failed, so did keychain repair.
Any ideas what to do next?
Odd thing is that I only have problems on two sites with auto log in, but I suppose this keychin problem needs to be fixed anyways.

I get this message, my name blocked out with XXXXXX

Repair started
Checking keychain configuration for XXXXXXXXXXX (user ID=501)
Home directory is /Users/XXXXXXXXXXXXXX
Checked login keychain
Checked password for ~/Library/Keychains/login.keychain
Checked settings for ~/Library/Keychains/login.keychain
User differs on ~/Library/Preferences/com.apple.security.plist, should be 501, owner is 0
Owner not corrected on ~/Library/Preferences/com.apple.security.plist, reason: No such file or directory
Checked default keychain
Checked keychain search list
Checked contents of ~/Library/Keychains/login.keychain
Checked contents of /Library/Keychains/FileVaultMaster.keychain
Warning: some problems were not fixed
Repair failed
 

·
Premium Member
Joined
·
9,103 Posts
Discussion Starter · #5 ·
Another interesting tidbit.

I now also added the problem website to the bookmarks in Safari and Firefox.

Safari fails the auto login as well, same as Camino, but Firefox is fine.

Do they all store the user ID and password for this site in the same place and retrieve the same information or does each browser have a different place where the info is stored?
 

·
Premium Member
Joined
·
31,013 Posts
Are you fully backed up??
 

·
Registered
Joined
·
379 Posts
......when you click "remember me" on a website.

I think the information somehow became corrupt because I now have to log in every time whereas before the log in happened automatically.
The window where you can tell the Mac to remember the User ID and password doesn't come up again since it already has that information (I assume), so how can I clear what may be corrupt information and reset this?
Aren't these stored in a cookie?
 

·
Premium Member
Joined
·
31,013 Posts
No - not crash


a) try booting from the backup see if it is the same issue.

b) if it is then do a current clone and try cleaning plist and perhaps keychain

also if you have not - run a full Onyx and the Keychain repair.
 

·
Premium Member
Joined
·
9,103 Posts
Discussion Starter · #10 · (Edited)
Well, I fiddled around on the weekend on and off.

Tried different browsers - Safari had the same problem as Camino, but Firefox auto logged me in every time.
Then found a program that checks plists. All my plists checked out OK.
Then found another Microsoft page about repairing keychain since I had an error there. Turns out you need to run the key chain repair a few times - first time around it didn't correct the key chain error, but second time around it did.
So keychain was fine now, but the log in problem still persisted.
Next step was to trash the Camino plist.
Made no difference.
Then I trashed Camino and it's three associated files completely and did a fresh download and install of Camino.
Was actually quite fast to do and Camino runs much faster now than it did before.
But the d..... problem was still there.
And Firefox was still happily doing the auto login as if there was no problem.

And then the breakthrough came.
The admin of the website posted a comment and I received an email that there was a new post in the thread where my problem was being worked on.
I had received those emails before and I just click on the link and get to the message. However, this time it dawned on me, how come I can get into the site without having to re-enter my user ID and password if I click on the link and not if I click on the bookmark????????
Well, after comparing URLs, I found out they are not the same.
Seems the site had changed URLs and even though the old URL was still valid and would bring up the main page asking me to log in, as soon as I logged in manually, the URL changed automatically to the new URL.
However, since the log in information is entered at the bottom of the page and I was focusing on that, I never noticed that the URL changed as soon as I hit the 'log in' button after entering my data.
So now I changed my bookmark to the new one, and everything is fine.

Boy, what an episode and a ton of wasted time.
 

·
Premium Member
Joined
·
31,013 Posts
Good tip - tried it with Safari on ehMac - will see if that resolved my long standing erratic log in issue.
Mine is fine on Camino and erratic on Safari.
 
1 - 11 of 11 Posts
Top