Canadian Mac Forums at ehMac banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys, new here...a friend recommended this place, so don't fail me :D

I recently did a 7 pass erase of my hard disk and reinstalled OS X.

I then tried to use Software Update, however, it was extremely slow to find updates (taking up to an hour) and when it did, it started to download them before saying the download had failed:

A networking error has occurred: request timed out (-1). Make sure you can connect to the Internet, then try again.

A networking error has occurred: timed out (-1001). Make sure you can connect to the Internet, then try again.


I tried deleting the Software Update preferences but it had no effect. In the end I downloaded the Combo update installer from Apple downloads. I've just tried running Software Update again and it is extremely slow again and I'm still getting the same message as above :mad:

Didn't have a problem with it before I erased and reinstalled OS X. My firewall is enabled but it was enabled in the past without any issues. I've tried restarting a number of times and I even did another reinstall of OS X but no luck.

Internet speed seems fine (8 Meg connection) and the fact it's been slow over the past couple of days kinda rules out a slow Apple server...I'm at a loss. Any help would really be appreciated, thanks!
 

·
Premium Member
Joined
·
3,752 Posts
Since Macs have moved to Intel, it seems that the old universal cure is required more and more often... Reboot!

Otherwise, check your modem/router for firmware update. I had download problems when my service speed increased to 8 megs
 

·
Premium Member
Joined
·
7,069 Posts
Are you using a program like Little Snitch or anything else similar? It's possible Software Update's download mechanism is being blocked. Another way to test this is to run the command:

sudo softwareupdate -i -a

in the Terminal and see if it works. Of bonus it's faster than Software Update normally.

Command breakdown:
sudo (Super User Do - requires a password to execture)
softwareupdate (Command Line version of Software Update)
-i (Install)
-a (All)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Thanks for the replies.

I've tried restarting numerous times with no luck. As for my router firmware AFAIK it's up to date and I've tried restarting it in the hope it would do something :eek:

Chealion, I've done a clean erase and reinstall of OS X. I haven't loaded any other 3rd party programs yet. I tried running the command and this is what I got:

Software Update Tool
Copyright 2002-2005 Apple

2007-08-06 00:01:46.264 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...mYp8fMxJCfB22drKT5CMvxC/022-3271.English.dist
2007-08-06 00:01:46.264 softwareupdate[355] *** Unable to use product 022-3271.
2007-08-06 00:02:16.520 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...7f3yjHFgrVnj9fGGVmWP27f/022-3281.English.dist
2007-08-06 00:02:16.520 softwareupdate[355] *** Unable to use product 022-3281.
2007-08-06 00:04:46.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...w5j2Z54VS7gvwCBWTsrNhzc/022-3445.English.dist
2007-08-06 00:04:46.260 softwareupdate[355] *** Unable to use product 022-3445.
2007-08-06 00:06:16.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...sBZm7CQtNCchj7x2b4fJYRt/061-1603.English.dist
2007-08-06 00:06:16.260 softwareupdate[355] *** Unable to use product 061-1603.
2007-08-06 00:06:55.184 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...xstvP8vxcfnCmjKXTGHV7dh/061-1605.English.dist
2007-08-06 00:06:55.184 softwareupdate[355] *** Unable to use product 061-1605.
2007-08-06 00:08:16.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...vYfHLbXtS6gVyPTx5jt9ZG9/061-1681.English.dist
2007-08-06 00:08:16.260 softwareupdate[355] *** Unable to use product 061-1681.
2007-08-06 00:08:46.520 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...5xWbQ3VmJWc8m9Tj2hpWmHL/061-1683.English.dist
2007-08-06 00:08:46.521 softwareupdate[355] *** Unable to use product 061-1683.
2007-08-06 00:10:16.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...7LmfDDmvjjKCfNvYXVpgrk5/061-1684.English.dist
2007-08-06 00:10:16.260 softwareupdate[355] *** Unable to use product 061-1684.
2007-08-06 00:11:46.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...byBMst5C6kYzJ7V7nMrrJNq/061-1685.English.dist
2007-08-06 00:11:46.260 softwareupdate[355] *** Unable to use product 061-1685.
2007-08-06 00:13:16.260 softwareupdate[355] *** Failed to load distribution file at http://swcdn.apple.com/content/down...XggcsmMRmfXGnLbdBv32bSf/061-1686.English.dist
2007-08-06 00:13:16.260 softwareupdate[355] *** Unable to use product 061-1686.


It kept going like that but you get the gist, I think :rolleyes:

It's strange because Software Update finds the updates (after what seems an eternity) but when I try to download them it seems to time out and I get the message in the first post.
 

·
Premium Member
Joined
·
7,069 Posts
That's really odd it's having such an issue finding the files - it sounds like a network issue - specifically DNS.

I'd try changing the DNS servers being used (can be done by going to the Network Preference Pane and filling in DNS Servers) to something such as the ones provided by OpenDNS to see if that fixes the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
I don't see anything about DNS in network preferences :confused:

A bit of an update...I ran Software Update again late last night and after an hour searching it found the updates but when I tried to install them I still kept getting the timed out message, so I restarted the router whilst keeping Software Update open with the updates it found and then tried to install them again. This time they downloaded quickly and installed without a problem.

However, Software Update is still taking 30 minutes to tell me there are no new updates (as I'm now fully up to date) :confused:
 

·
Premium Member
Joined
·
31,013 Posts
try this

Slow web lately? try this - paste into the DNS Servers window in your Network Setup

208.67.222.222
208.67.220.220
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
My problem appears to have been solved without me doing anything...just tried Software Update again and it took less than a minute...random but I'm not complaining :D

Thanks everyone for their help :clap:
 

·
Premium Member
Joined
·
7,069 Posts
Vazza - My assumption is that resetting the router fixed the issue, possibly passing on new DNS information (or maybe not). It works now, that's what's most important.
 
1 - 10 of 10 Posts
Top