Canadian Mac Forums at ehMac banner
1 - 20 of 22 Posts

·
Registered
Joined
·
316 Posts
Discussion Starter · #1 ·
I installed the Security update yesterday and since then I've been having an argument with Airport. Whenever the computer goes to sleep, it won't connect once it wakes. It looks like it doesn't "see" the network. Trying to join by logging in doesn't work.
The only thing that seems to work has been to restart, which is alright until I answer the phone and it goes to sleep, and here we go again.
I looked at Applecare and they show a problem for MacBooks and Tiger, I'm not there but I followed those steps. Haven't tested it yet because I want to get this off and have my supper.

The Airport bars are greyed. Kismac and iStumbler can't find a network. Restart fixes it.

What else? It doesn't happen to my wife's G5; my computer stays connected once it's up and running, until it goes to sleep, of course.

I'm now on a G4 Ti-Book 667, panther. (Sympatico's wireless but that's ruled out since wifey's doesn't have this problem.)
 

·
Mac Guru
Joined
·
14,627 Posts
Reset the AirPort card. Remove, leave out for 30 seconds, then re-install. Restart.

Might do nothing, might fix the problem. For now, set your unit to sleep 'never' unless you specifically tell it to or close the display.
 

·
Registered
Joined
·
316 Posts
Discussion Starter · #3 ·
Thanks Lars, I hope it's something simpler than that but I've got to change a drive anyway.

I had a look over at the Apple discussion board and there is all sorts of similar issues after this last update.

Some people are claiming success by removing a duplicate file called Appleairport2.kext. That worked for a short sleep but not the long one.

I took part of your idea and tried a reset but that didn't help.

I've reinstalled the driver from the Apple site and it's worked for the short sleep. I'm going for a long sleep myself so we'll see if this works in the morning.
 

·
Premium Member
Joined
·
17,845 Posts
Having had a computer go to sleep during an update :eek: I now set my computers to sleep never. May be a bit drastic for your needs. Other alternative go back to the system back-up you created before the update :D and wait for Apple to sort this one out.
 

·
Registered
Joined
·
1,455 Posts
I've been having this problem on and off for months, so I'm not so sure it's necessarily related to the security update.

Do you have your SSID hidden (i.e., your network name is not visible)? I do and I wonder if this is not part of the problem. On my machine (only happens to my mini, not my iBook), upon wake from sleep and failure to connect, I try to join "other", type in the network name and password. Then one of two things happens, either it connects or (much more frequently) I get a network error stating that the network does not support that type of encryption (WPA2). The only solution is to unplug the APX and plug it back in.

I got temporary relief for a few weeks when I went into the network prefs for AirPort and changed the settings to "By default join: preferred network". But in the last few days it has started again, though now at least it will let me rejoin without unplugging the APX unit.

Not sure what to do, but I think my next step will be to unmask the SSID and see if that works.

Let me know if you find a solution.
 

·
Registered
Joined
·
316 Posts
Discussion Starter · #7 ·
Thanks, macsackbutt.
This is a different kind of problem. For example, after sleep, no networks are visible at all and can't be found by "stumblers" Kismac doesn't give you the off/on choice. (Actually, I believe it's this switch that is corrupted but I don't know how to get there.)

It's not a router issue. Works fine on restart, wife's G5 and Tiger work fine. There are usually a couple of networks visible, they're gone too, so it's not the ssid thing.

There is a long list on apple's site and apparently others.

It only affects g4 (laptops?) running panther. Everybody else seems safe.

So, the warning, if you're running Panther on a G4, wait. Don't install the latest security update.
 

·
Registered
Joined
·
316 Posts
Discussion Starter · #8 ·
Okay, it looks like there is a fix (and I got it from the Apple discussion forum, not you guys: first time that's happened).

Run the UpdateCombo10.3.9 over it and the problem is gone. The Tibook has had a 3 hour sleep and an 8 hour sleep (better than me) and found the network both times.

At a tech level, it seems to revolve around AppleAirPort2.kext. The Security update seems to put an older one in and increases password/encryption sensitivity. The older Combo update puts in a newer .kext, go figure. (Note, this explanation is the KISS version, I really understand little of what I'm talking about here.)

Here's a couple more weird things about it. The Combo update says it will now install 0 data on your hard drive. Running Sofware Update afterwards says nothing new is needed.
 

·
Registered
Joined
·
1 Posts
Thanks!

Can you please post a link to this 10.3.9 update... I don't know which Apple discussion board you are talking about.

Thanks for the info though, I couldn't believe I found an answer to my question so fast... gotta love google!
 

·
Premium Member
Joined
·
1,234 Posts
Hi,

10.3.9 Combined Update.

I've heard that the Security Update problem can be fixed by finding and moving to the desktop the following files.

AppleAirport2.kext
AppleAirportFW.kext

If it doesn't come up in the search bar, try digging it up in the folder /System/Library/Extensions

Restart and see how it works. If the problem is solved then trash the files.

s.
 

·
Registered
Joined
·
1,455 Posts
Isn't this issue solved by:
System Preferences > Network > Airport > By default, join preferred Network (make sure your network is listed there) ?
Seemed to work for me (as I mentioned in my own response). *touches wood and mutters a short, hopeful incantation*

Archangel: glad you managed to get your problem solved too.
 

·
Registered
Joined
·
316 Posts
Discussion Starter · #14 ·
Isn't this issue solved by:
System Preferences > Network > Airport > By default, join preferred Network (make sure your network is listed there) ?
Nope, the problem is that after sleep, it's like Airport doesn't wake up. No networks are visible, by any method, to join. It's an Airport firmware issue.

BTW, dragging files to the desktop copies them. Moving them to trash removes them. You don't have to trash them right away. Check what works and put them back if you want.

That didn't work for me although on reflection I'm wondering if the 2.kext is for the extreme and the other .kext is for regular airport (mine). In any case, there was enough info on the Apple discussion board to realize that trashing either didn't really fix it.

It can affect some Macbooks and tiger, Apple has steps posted for that. Those steps don't work for G4/panther.
 

·
Premium Member
Joined
·
4,626 Posts
I've tried every 'fix'.

The only method that works 100% is turning airport off then on again from the finder menu (the little icon). From my personal experience, that's been the only reliable way of getting it to work.

I don't know about you guys, but I'm VERY sick of this stupid bug. They've had PLENTY of time to fix it by now.

I find sometimes my wireless just goes dead randomly..... very seldom, but when it does, sometimes a reboot is the only thing that gets it back up... maybe it's the router for that one...
 

·
Registered
Joined
·
1,455 Posts
Looks like Apple has issued a patch for the Panther AirPort wake-from-sleep issue. Run software update.
 
1 - 20 of 22 Posts
Top