Canadian Mac Forums at ehMac banner
1 - 20 of 24 Posts

·
Premium Member
Joined
·
30,929 Posts
Discussion Starter · #1 ·
I switched to a single 1 gHz and have had several Safari crashes today but nothing else.
Anyone else with Safari hiccups??
 

·
Premium Member
Joined
·
30,929 Posts
Discussion Starter · #3 ·
I'm suspecting RAM as it was also stable on the DP800. :(
Finicky MDDs
 

·
Registered
Joined
·
68 Posts
Try resetting Safari from the Safari menu. Note though, that you will lose all your settings.

Also, try deleting your com.apple.quicktime.plist file (located in your preferences folder). This file has been known to cause these problems if its get corrupt.

Hope this helps.
 

·
Mac Guru
Joined
·
14,627 Posts
Safari hasn't crashed in weeks on end now for me. Looks good on my end.
 

·
Registered
Joined
·
282 Posts
Yo MacDoc...

I'm having MAJOR problems with it!

Everything was running perfectly until I installed the update, now the thing will quit before the page load...

Is that what it's doing with you?

I DID notice the bug report detailed a font rendering issue, although checking into Fontbook revealed nothing.

I've also tried removing ALL Safari components from the machine, downloading the full install from Apple's site and reinstalling the app to no avail.

I have also tried resetting Safari, destroying the cache, changing the default web-font in the prefs before the first page loads and installing the latest Java engine as well as testing the load against a standard HTML page with no dynamic elements and it still crashes.

I used Onyx to fix my privileges and purge my various caches to no avail either...
 

·
Registered
Joined
·
282 Posts
My MDD at home runs it perfectly.

In fact, all other MDD's I've upgraded run fine at work. It's just one 867DP I'm having problems with...
 

·
Registered
Joined
·
42 Posts
All fine here before and after the update.
I'm running Panther on a TiBook G4/400


Cheers,
B.
 

·
Left The Building
Joined
·
8,381 Posts
Never had a real problem with Safari, it's always been very stable and has never crashed on me, no matter what version, whether under Jaguar or Panther.

The only issues I've had are relatively minor, consisting of incompatability with certain websites (mostly fixed), and window sizing. For example, when on ehMac composing a message, if I click "Preview Post", the preview window opens as it should. However the next time I open a new window, it's very small, the size of the preview window. Safari seems to remember the last window size used, and the next time one is opened, that's the size you get even if it's teeny-tiny.
 

·
Premium Member
Joined
·
30,929 Posts
Discussion Starter · #14 ·
I'm having other unexplained quits and this is only after updating to 10.3.2 which I had not done previously.
Everything had been rock solid including Safari 1.2 now FM and Entourage both died and this is with a different CPU and RAM so something is not kosher.
I had a client in today with a Panther situation PS and Illustrator both would "unexplained quit" and we went through that machine with a fine tooth comb as it was so repeatable and the only fix was a clean Panther install.
He had just done the 10.3.2 update when it all started.

I should have listened to my instincts on that when I stayed off it for so long and all was working really well.

One more anomaly tonight and it's clean install time.

On another note - we've been running Panther on a DP 500 wiht a 64 meg card and all of the staff are bug eyed about the "feel". It's damn quick. Michael I see why you like yours.
Same theme the GarageBand tester is singing the praises of the DP 500 for his work.

Cache is king it appears....but it needs the faster video to get the synergy going.
:cool:
 

·
Lifetime membership
Joined
·
9,265 Posts
I've had Preview do unexpected quits right after I had Safari
have the same problem, It seemed to help if I repaired the
permissions, Ran MacJanitor and then logged out and back in.

Doing this ritual seems to help for a while,
But lately it's starting to become a daily ritual.

Dave :cool:
 

·
Honourable Citizen?
Joined
·
4,853 Posts
I've just experienced 5 Safari crashes in a row, when trying to download some of the posted GarageBand music at this site: http://www.macband.com

Although Safari seems to crash more than any other app I use in OSX, this is the first time I've seen anything like this.

The thing I love about OSX - I've only been on X for about 3 months - is that the system just keeps chugging along. And on my old machine rebooting was close to a 10 minute process.
 

·
Premium Member
Joined
·
30,929 Posts
Discussion Starter · #18 ·
It's been fine lately - I ran Onyx several times and then repaired permissions once more with the Disc Utility just so I could see the progress.

I suspect it might have been a bad piece of RAM originally causing some corruption that persisted a bit.
Nothing lately. :D :cool:
 

·
Registered
Joined
·
2,198 Posts
Safari 1.2 consistently crashes for me when I visit http://www.apple.com/ (it's crashing in CFDictionaryGetValue in com.apple.CoreFoundation).

What's interesting is that I wiped my computer clean and re-installed Mac OS X 10.3 and grabbed all of the software updates and Safari 1.2 worked again. However, after I installed QuickTime 6.5 and iLife '04, it started crashing again.

Nevermind the fact that I've *never* been able to get iMovie 4 working. Yay iLife '04, I suppose.
 
1 - 20 of 24 Posts
Top