Canadian Mac Forums at ehMac banner
1 - 2 of 2 Posts

·
Student of ehMac
Joined
·
103 Posts
Discussion Starter · #1 ·
I am currently trying to set up my primus ADSL connection. The problem doesn't seem to be the connection, but a restricted service issue. The internet loads the first primus page (signup.primus.ca). Next, one chooses language preference and this is where I think that primus verifies your account. Anyway, my computer doesn't load any more pages. The funny thing is that it will load The Weather Network - City Weather - Vancouver, British Columbia
but, as I said, no other pages. The computer also successfully pings, or however you describe that, as I was able to ping the primus tech support.

Now, I've been left in limbo, primus has been 'investigating' for the past two weeks. Today, I was given a hint that they need to reset the account with a 'third party', which was revealed to be Telus (I'm in Vancouver). However, the agent knew nothing more, conveniently.

Can anyone recommend what Telus department I need to speak with, or what technical issue I might be faced with? I tried to call Telus, but didn't know which of its thousands of options, to choose.

Sorry for the rant, but I thought there might be someone out there in ehMac world that has been through this or has any thoughts.

Again, its not a software issue, the computer 'pings' and load one or two pages, plus it works on other wired and wireless connections. And, yes, the account details are correct.

:mad: :confused: :mad::confused: :mad:
 

·
Registered
Joined
·
4 Posts
Primus DSL slow on Airport X/E, fast direct.

Hi, I've been having fun with Primus as well, in Toronto. I had Sympatico disconnected just before I switched to Primus, and that was a bit of a headache. It took Bell a while to disconnect my line card. Now Primus works pretty well, when directly connected to my 10.4.10 iMac G5. I get 2.4 Mbs DL and 640 Kb UL. Not too bad.

However, I have the same problem as you, when I connect the Speedtouch DSL modem to either my factory reset Airport Extreme Base Station, or Airport Express. I get very slow speeds, 300 Kb DL and can't even perform the UL test. It stalls on many web pages, which leads me to believe that it can't upload through either of the routers.

Primus tech support says there should be no issues with Apple Airport Base Stations, but there's obviously something strange going on. I even factory reset the DSL modem each time, before connecting directly or to the Airport.

I have tried disabling NAT, and playing with the limited settings on the Base Stations, but nothing makes a difference.

Any insight would be greatly appreciated.

Thank you.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top