Canadian Mac Forums at ehMac banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just recently purchased a PowerMac G4 it worked fine for a while but then the OSX started to freeze causing me to restart the system. Now when I turn on the system it loads the apple screen then shows it starting Mac OS X then just sits at the light blue screen with the mouse. Whats wrong with it? Also, I then proceeded to put another 40GB HD in and tried installing OS X 10.3 instead it was working fine formated the HD then with a min left in the install an error occured and the installation failed What was with that happening? Thank You any one that can help me with my troubles and I hope my Mac isn't scrap already.
 

·
Premium Member
Joined
·
9,103 Posts
First thing I would check is the memory chips installed.
Are they all original Apple?
If not, take all the non-Apple ones out and see if that helps.
Make sure the Mac is off and you grounded yourself by touching a metal part on the power supply before you touch them.
Also make sure the memory chips that are in the mac are fully seated. Sometimes you have to push quite hard to get them to seat in the connector.
 
1 - 2 of 2 Posts
Top