Canadian Mac Forums at ehMac banner
1 - 4 of 4 Posts

·
Hotwiring another cessna
Joined
·
389 Posts
Not a bad browser if I do say so myself, just can't seem to part with Mozilla and Camino. Must be the tab browsing...
 

·
Premium Member
Joined
·
6,795 Posts
OmniWeb, and the company that makes it The OmniGroup, have been around since OS X was still NeXTSTEP. The first version for os X (v3 or 3.5) wasn't that great but version 4 was quite popular. It was plagued by Omni's web rendering engine though, which had a hard time with some things like more advanced CSS.

With the most recent release, v 4.5, they have dumped their own rendering engine and are using Apple's WebCore and JavaScriptCore which are the engines that drive Safari. Not only is it now faster and more standards compliant, but they can spend more time working on their UI and let Apple do all the hard work with the rendering engine.

Probably the most amazing part (but not surprising considering how long they have been working with Cocoa) is that they acomplished all of this before Apple released any kind of SDK or developer documentation for WebCore other than a note saying "we don't recommend you use it yet".

Tres Cool!

--PB
 

·
Lifetime membership
Joined
·
9,265 Posts
Discussion Starter · #4 ·
I've discovered a tiny bug with the OmniWeb browser
on ehMac, It doesn't allow the user to preview a post
before posting, I found it too frustrating with having to
re-edit posts after posting because I couldn't preview
what the post would look like, I'll use it for surfing only
for now until the bug can be fixed.

The version I'm using is the OSX 10.1 version, Perhaps
the bug has already been fixed in the OSX 10.2 version.

Dave :cool:
 
1 - 4 of 4 Posts
Top