Canadian Mac Forums at ehMac banner

1 - 5 of 5 Posts

·
Registered
Joined
·
443 Posts
Discussion Starter · #1 ·
I inherited a broken G4 mac mini in the hopes that I could fix it. The problem with it was that it had absolutely no video output from the DVI port. When Powered on, it would sound the chime and you could hear the fan and hard drive running, but no video appeared. I have hooked it up to multiple working screens with not so much as a blip on the screen. The Hard Drive and Ram are in good shape (tested them elsewhere), but the Optical drive won't accept a CD. I don't know if this could affect other systems or not.

This leads me to believe that this is either the logic or the video card which is on the logic board and for all intents and purposes is the logic board. This is an old machine and I have no interest in replacing the logic board, but if anyone has any other suggestions as to the cause of this problem, please let me know.
 

·
Mac Guru
Joined
·
14,627 Posts
It's a throw away machine. Bad logic board. Solution: Replace logic board.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #3 ·
Yes, I haven't confirmed that the logic board is bad. I was hoping for suggestions that might cause this problem that aren't the logic board.
 

·
Mac Guru
Joined
·
14,627 Posts
Yes, I haven't confirmed that the logic board is bad. I was hoping for suggestions that might cause this problem that aren't the logic board.
Based on the symptom(s) and my experience with such symptoms, it's more than likely the logic board - very few other factors, especially on a Mac mini (if any), will cause no video symptoms.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #5 ·
What if the DVI port was damaged or somehow disconnected, I have a friend that owns a repair shop, but they don't deal with Apple very often, is it worth having him look at that?
 
1 - 5 of 5 Posts
Top