Canadian Mac Forums at ehMac banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I don't know if this is the right place to ask this question, but I'm hoping someone out there will have some HTML/Javascript knowledge that could help me out.

I'm having some issues with the viewport meta tag in an html document I'm creating.

The general idea of what I've made is that I've made a scrollable map with customized scrollbar that indicates where on the map you are using a bounding box that runs back and forth on a smaller map that displays the full width of it. This is contained in an indesign file with a digital publishing plugin installed (aquafadas).

The problem is, the property "user-scalable = no" doesn't seem to have any effect. Double tapping and pinching still cause safari to zoom, expanding the main map image and the relative position indicator outside the bounds of the ipad's screen. I've been testing the HTML just in the iOS safari for the meantime as if it doesn't stop zooming in safari, it won't stop zooming in the resultant ebook that's created.

Any reasons why the user-scalable property would not be working? Am I missing something? Is there another way to do this, possibly by disabling double taps for the html doc entirely?

Thanks for your time and help.
 

·
Premium Member
Joined
·
7,069 Posts
Hi brodie,

Are you setting the initial-scale and/or the width as well?

Additionally, I'm not sure when Apple added spaces around the = in their documentation - they used to have no spaces around the equal sign; eg. user-scalable=no.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Chealion,

Thanks for replying. For the record, I tried every variation for the meta tag I could think of, using the properties available. I also tried tweaking the syntax around the properties (the space before and after the '=')

However, I managed to figure out my problem this morning and was about to post my solution when you commented. Turns out it was just complete oversight on my part. I was using a js framework called iScoll4 to create the custom scroll bar and had forgotten that at some point when I was mucking around with the options in it, I had enabled the zoom property that's provided in the framework. Not changing it to false overrode my meta options.

Thanks for trying to help though!

Cheers,
Brodie
 
1 - 3 of 3 Posts
Top