Canadian Mac Forums at ehMac banner

1 - 9 of 9 Posts

·
Registered
Joined
·
459 Posts
Discussion Starter #1 (Edited)
Greetings all,

I have for sale a 20" Apple Cinema Display. Screen is great, cosmetically everything is fine. Original box is included, see attached pic.

Only thing about it is I don't think the ports on the back work. I never needed them so it wasn't an issue for me and I never tried to troubleshoot the problem.

I'm setting the asking price at $375 or best offer.

Feel free to inquire via PM or email.

Thanks
 

Attachments

·
Registered
Joined
·
476 Posts
Could you test the back Ports?
 

·
Registered
Joined
·
459 Posts
Discussion Starter #6
Exactly. Would it be too hard to plug things into them to test the ports?
Why would that be too hard? That's how I know they don't work. Nothing I plug into the ports works/worked, so I assume there's some kind of hardware issue in there.

I don't have the means to pull the monitor apart and inspect the innards. Maybe it's as simple as a loose screw, or maybe it needs a new Johnson Rod. I don't know.
 

·
Premium Member
Joined
·
10,314 Posts
Why would that be too hard? That's how I know they don't work. Nothing I plug into the ports works/worked, so I assume there's some kind of hardware issue in there.

I don't have the means to pull the monitor apart and inspect the innards. Maybe it's as simple as a loose screw, or maybe it needs a new Johnson Rod. I don't know.
Johnson rod. Nobody knows. Could be a kacked widget next to the doohickey also.
 
1 - 9 of 9 Posts
Top