Canadian Mac Forums at ehMac banner
1 - 8 of 8 Posts

Premium Member
Joined
42,782 Posts
Discussion Starter · #1 ·
I have an Epson V750 scanner that is intermittently not recognized by my Mac Pro. If I temporarily unplug the USB cable or following a power outage, Epson Scan and Image Capture won't see it or be able communicate with it. Sometimes, even the profile for the V700/750 disappears from the System Preference setting for Printers and Scanners.

Strangely enough, if I plug the USB cable into my MacBook and attempt a single scan using Image Capture, then plug the USB cable back into the Mac Pro, all is well again.

I've updated and replaced all of the drivers and completed similar maintenance. Anyone have any insight into what might be happening here? I can't figure out why using the scanner on a second computer would make it recognizable to the first one.
 

Premium Member
Joined
15,942 Posts
I've updated and replaced all of the drivers and completed similar maintenance.

Did you delete the scanner from your system preferences before you replaced any drivers and any software and then restart your Mac pro???

I guess you tried checking out some of the hits with a Google search such as this:

I would be almost tempted to try doing an SMC reset on your Mac Pro. It shouldn't break anything further especially when it's already partially broken. 馃槒


- Patrick
=======
 

Premium Member
Joined
42,782 Posts
Discussion Starter · #3 ·
Yes, I've restarted the Mac Pro, deleted the scanner from system preferences, etc. I've read 40 or 50 Google links, which don't answer my main question: why would running the scanner on another computer cause it to be recognized when I plug it back into my regular computer?
 

Premium Member
Joined
15,942 Posts
why would running the scanner on another computer cause it to be recognized when I plug it back into my regular computer?
which don't answer my main question: why would running the scanner on another computer cause it to be recognized when I plug it back into my regular computer?
I'm going to take an educated guess that there is something happening in the various connections forcing the printer to create a new but different setting allowing the printer to work as expected.

Does it continue to print correctly after you have done the switch around or do you need to go through the process again every time you need to print from your Mac Pro???

If so, I would suspect an old corrupt .plist or some such, but that does not explain why any new working .plist would stop working or disappear and not get used.

Definitely a strange one.


- Patrick
=======
 

Premium Member
Joined
15,942 Posts

Premium Member
Joined
42,782 Posts
Discussion Starter · #6 ·
Yes, that was my first course of action.
 

Registered
Joined
1 Posts
I have an Epson V750 scanner that is intermittently not recognized by my Mac Pro. If I temporarily unplug the USB cable or following a power outage, Epson Scan and Image Capture won't see it or be able communicate with it. Sometimes, even the profile for the V700/750 disappears from the System Preference setting for Printers and Scanners.

Strangely enough, if I plug the USB cable into my MacBook and attempt a single scan using Image Capture, then plug the USB cable back into the Mac Pro, all is well again.

I've updated and replaced all of the drivers and completed similar maintenance. Anyone have any insight into what might be happening here? I can't figure out why using the scanner on a second computer would make it recognizable to the first one repaired by dubai printer repair
having same issue.
 

Premium Member
Joined
15,942 Posts
having same issue.
When did the problem start or has it always existed???

Have you checked or reinstalled the proper software???

If the latest software is giving the problem, maybe try going back to a previous version if it actually still works properly.

Have you contacted Epson technical support for any help or suggestions???

It has or had some good reviews even if it was 10 years ago, software and compatibility often changes:

And are you using the SilverFast Ai scanning software that it apparently came with and are there any updates for it available??





- Patrick
=======
 
1 - 8 of 8 Posts
Top