ehMac banner

1 - 8 of 8 Posts

·
Registered
Joined
·
818 Posts
Discussion Starter #1
I was very excited to try out my new iPhone's LTE data today since Rogers activated the SOM overnight. However, I only get 3G for some reason here in the Beaches Toronto. Sux.
 

·
Registered
Joined
·
818 Posts
Discussion Starter #3
I just read elsewhere that Rogers is having issues with LTE today. Hopefully they'll fix it soon.
 

·
Registered
Joined
·
818 Posts
Discussion Starter #4
OK so I went out and tried LTE it is blazingly fast as everyone has said. Unfortunately when I'm home I do not get an LTE signal, it says 3G. However, I did a speed latest on the 3G and it is faster than my wireless so I assume it must be HSPA.
 

·
Registered
Joined
·
387 Posts
Damn you lucky ppl within range of LTE speeds, debating on heading down to sqaure one apple store to grab my applecare but to mainly test out LTE /nerd :cool:
 

·
Registered
Joined
·
818 Posts
Discussion Starter #6
I think you'll be shocked with the LTE speed I was. I too wish I got LTE at home. But HSPA isn't too shabby at least. Hopefully Rogers expands the LTE in Toronto soon. This is the first time using Siri to post anything. Boy is she ever accurate I can't believe how well this is working
 

·
Registered
Joined
·
118 Posts
I am wondering why out here in beautiful Northwest Halton, Bell has had LTE for the past several months but Rogers only has 4G with no plans to bring LTE to the area. And Rogers claim to have the largest LTE coverage in Canada.
 
1 - 8 of 8 Posts
Top