Canadian Mac Forums at ehMac banner
1 - 20 of 21 Posts

·
Premium Member
Joined
·
25 Posts
Discussion Starter · #1 ·
Hi: My iMac goes to sleep during a longer download. Even though it is set for 3 hours it still goes to sleep at the default 10 minutes. I have seen a work around to fix this in one of the back issues of Macworld but can't find it now. Can anybody help me out with this? Thank you, Glenn
 

·
Mac Guru
Joined
·
14,627 Posts
A Mac will not go to sleep if it is downloading - downloading is considered an active task which cancels any set scheduled sleep time otherwise due to inactivity.* Are you sure the display simply isn't going dark? That isn't the same thing. Desktop or portable computer?


* Unless of course the Mac is broken/has some sort of issue.
 

·
Premium Member
Joined
·
17,859 Posts
Computer or just the display?
 

·
Premium Member
Joined
·
25 Posts
Discussion Starter · #6 ·
machine sleep

Yes, all software is up to date. This is not a new phenomenon with this machine. It has acted like this since new in 2011. I always thought Apple would put out a fix but no such luck. On long downloads I need to check every 15 minutes to click the computer back on and continue the download. Appreciate your help. glemac
 

·
Premium Member
Joined
·
6,076 Posts
What kind of downloads is it going to sleep during? A download in and of itself won't prevent the system from sleeping on the regular schedule - the application must tell the system not to sleep.

For instance, Transmission has a specific option to prevent the system from going to sleep while a transfer is in progress.
 

·
Premium Member
Joined
·
16,139 Posts
Ouch! I this seems to be quite a general problem, especially those running ML, and with all the latest updates installed according to many discussions.

Even using Caffeine (Lighthead - Caffeine) doesn't seem to help many.

The general fix that seems to have fixed the problem for many was to:

• delete /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
• reboot

• If it won't solve it, another helpful step could be resetting the SMC: Intel-based Macs: Resetting the System Management Controller (SMC)

I would have suggested the same as monokitty's suggestion and would have thought it should work, but it seems that for many who have tried changing the 'sleep' time to x hours or never, their Macs still go to sleep without any human input, and many within just 10 minutes. :(

Both with large downloads and sometimes iTunes and video stuff.
 

·
Mac Guru
Joined
·
14,627 Posts
What kind of downloads is it going to sleep during? A download in and of itself won't prevent the system from sleeping on the regular schedule - the application must tell the system not to sleep.

For instance, Transmission has a specific option to prevent the system from going to sleep while a transfer is in progress.
This.

Failing this, I'd reset the SMC as well.
 

·
Premium Member
Joined
·
17,859 Posts
What about the check box for "Put hard disks to sleep when possible", Is it unchecked?
Agreed! It should be unchecked.

I have found this setting troublesome for as long as I can remember.
 

·
Premium Member
Joined
·
16,139 Posts
Agreed! It should be unchecked.

I have found this setting troublesome for as long as I can remember.

I agree.

Even when checked and my MBPro plugged in, the HD will often spin down after about 2-3 hours. And with the sleep set to 'Never'. Seems to be some sort of "over-ride" built into the OS X system.
 

·
Mac Guru
Joined
·
14,627 Posts
Even when checked and my MBPro plugged in, the HD will often spin down after about 2-3 hours. And with the sleep set to 'Never'. Seems to be some sort of "over-ride" built into the OS X system.

There's a problem with your MacBook Pro. A drive should not spin down if it is unchecked to do so. Either that, or your drive isn't spinning down and you're confusing it for something else.
 

·
Premium Member
Joined
·
16,139 Posts
Nothing wrong with my MacBook Pro, or even my older Mac portable when using AC power setting, and I've also noticed this "spindown" thing with nearly all desktop Macs that ran/run various OS X versions with their boot drive.

My normal settings are: Sleep = Never and Put the hard disk(s) to sleep when possible = deselected

Maybe the reason is because nearly all Macs have had their internal HDD drives replaced and maybe they are controlling the spindown as explained in this article:

Hard Drive Sleep

Anyway, I don't know if my MB Pro will exhibit the same thing, but I sure won't be able to tell as I recently replaced its HDD with an SSD. ;)
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top