Canadian Mac Forums at ehMac banner
1 - 3 of 3 Posts

·
Banned
Joined
·
14,050 Posts
Discussion Starter · #1 ·
blackbook 2 ghz, 2 GB RAM, 10.4.9

after coming back to os x from xp via bootcamp my clock is slow by 4 hours
no amount of waiting for the clock to fix itself helps
clicking the auto off then on doesn't help
neither does trying different sync clocks

it is set for automatic with Apple Americas/U.S. (time.apple.com)

if i check off auto, set the clock manually and then check auto back on all is ok

when i boot into windows via bootcamp, the clock is also slow by the same amount, but fixes itself within about 3 minutes

anyone else have this problem?
and/or
know how to fix it?
 

·
Registered
Joined
·
619 Posts
You may want to check the network settings for OSX just to make sure that the clock can actually make a connection to the server. You may even want to try using another time server (time.nrc.ca) just to make sure. It seems that the auto time correction in OSX is having trouble connecting.

The time change is apparently due to the way Windows and OSX handle time: Windows sets the time for the specific timezone while OSX picks up Universal Time and then internally adjusts the time based on the system preferences.
 

·
Registered
Joined
·
682 Posts
mwahahaha. You are in the clutches of bootcamp! A partition and drivers set-up assistant that works sorta well, most of the time!

The issue you mention is a known issue and has to do with the way windows and Mac OS X differ with how they set the time. It is relatively complicated and some people have attempted to reprogram some of windows XP to get it to work in harmony with Mac OS but I wouldn't recommend that unless you are well versed in software development and computer programming.

As far as I could gather from what the techies were saying, Mac OS gets the time from the GMT (Greenwich Mean Time) and then adds or subtracts the correct amount of hours according to the time zone you have selected in system preferences. Here's where things get cute: Windows XP, has a different way of storing the time with regards to the time zone so if you set your XP to Eastern time (which is GMT +5, if I'm not mistaken) when you reboot into Mac OS, you'll find your clock off by exactly 5 hours.

Have you downloaded the most recent updates to bootcamp, because I thought they had fixed this? One workaround, is to intentionally set your Mac OS or Win XP time zone settings the correct amount of hours ahead or behind so that you get the correct time; i.e. you set you set you Windows time zone to Eastern (or whatever depending on where you are) and then you set your Mac OS clock to GMT +1 (instead of GMT+5 for eastern) so that when it moves your clock ahead four hours, you've selected a time zone that counteracts the time change by subtracting exactly the amount of hours that are incorrectly being added and thus giving you the correct time!

I've spent hours and hours on the damned Apple message boards and had to stop using bootcamp because I couldn't get the wireless drivers to work after the iSight update. Apple has a forum entitled Bootcamp in their support forums. If you want to use Bootcamp, better bookmark that link, so that you can troubleshoot. Don't even call Apple, they won't touch bootcamp with a 10 foot pole!

If you aren't doing anything really heavy, like hardcore 3d gaming, then I recommend parallels. It works better than bootcamp in my opinion. I have a friend running autocad (architecture software) and Photoshop on it no prob and you don't need to reboot to switch between Mac OS and Windoz. It also supports many different versions of windows, not just Win XP (service pack 2) like bootcamp.
 
1 - 3 of 3 Posts
Top