Canadian Mac Forums at ehMac banner
1 - 7 of 7 Posts

· Premium Member
7,889 Posts
Discussion Starter · #1 · (Edited)
This is really strange and I could use some opinions.

Running an AGP G4, 1.3MHz, 1.5Meg of RAM and OS 10.4.10
About four weeks ago, out of the blue, I started to get kernel panics - one after the other.
I made another back-up with SuperDuper and then started checking memory, deleting some apps I had loaded and a few other things. All without success.
So I finally decided to re-install OS X and the problems just vanished.

The Mac was zipping along again, no more Kernel panics or other problems.

Now, yesterday and today, the Mac started to act funny - the cursor would freeze, videos would crash and kernel panics were back. Some of them I got just at the end of the boot up cycle, others at odd times. Reminded me of the Windows machine at the office.
So I ran the memory test, that seemed to be OK.
Then I booted off the OS X disk and repaired permissions and repaired each one of the volumes - two internally and 5 externally.
Repair was not necessary on any of the seven volumes, they all passed.
Permissions were repaired on the two internal volumes but when I ran "Repair Permissions" on the external volume where I had made a backup after I had all these kernel panics four weeks ago, about 1/3 through the repair cycle, everything just vanished from the screen and I was left with just a blue screen - no icons nothing.
I shut down the Mac and restarted - kernel panic at the end of the boot cycle.
Then I turned off the external drive that had the "corrupt" back-up on it and restarted. Everything worked fine.
Plugged the external drive back in and deleted the back up with the corrupt OS (from 4 weeks ago) and suddenly the Mac runs very much faster, really snappy and so far no more issues.

Long story but I thought the background was relevant.

Question: Is it possible that a corrupt OS on an external FW drive was causing these problems? Hard for me to understand since I never tried to boot off that drive so I thought it would have no bearing on what was going on with my main drive.

· Premium Member
7,889 Posts
Discussion Starter · #3 ·
Yes, it has an upgraded processor in it. It's actually a 1.42GHz one.

I just checked back - that was put in almost a year ago and I haven't had any problems until these kernel panics four weeks ago.

But I also seem to have a memory problem.
I ran rember on all available memory over night and it tells me I have a problem.
Just doesn't tell me where and what it is.
If I run rember on either 1 or 10Meg chunks, everything is fine.

Is there a better memory tester for the Mac? One where you can specify which memory module it should test and do one memory module at a time?

The rember log shows this:

Memtest version 4.2 (32-bit)
Copyright (C) 2004 Charles Cazabon
Copyright (C) 2004, 2005, 2006 Tony Scaminaci (Macintosh ports)
Licensed under the GNU General Public License version 2 only

Mac OS X 10.4.10 (8R218) running in multiuser mode
Memory Page Size: 4096
System has 1 PPC processor(s) with Altivec
Requested memory: 1147MB (1202905088 bytes)
Available memory: 1147MB (1202905088 bytes)
Allocated memory: 1147MB (1202905088 bytes) at local address 0x02008000
Attempting memory lock... locked successfully
Partitioning memory into 2 comparison buffers...
Buffer A: 573MB (601452544 bytes) starts at local address 0x02008000
Buffer B: 573MB (601452544 bytes) starts at local address 0x25d9f000

Running 255 test sequences... (CTRL-C to quit)

Test sequence 1 of 255:

Running tests on full 1147MB region...
Stuck Address : ok
Linear PRN : setting 1 of 16ok
Running comparison tests using 573MB buffers...
Random Value :  ok
Compare XOR :  ok
Compare SUB :  ok
Compare MUL :  ok
Compare DIV :  ok
Compare OR :  ok
Compare AND :  ok
Sequential Increment:  ok
Solid Bits :

· Premium Member
7,889 Posts
Discussion Starter · #5 ·
If you mean stuck address as a problem it's not.
Not sure what you mean by that.

Rember said I had a problem, the log shows what I posted above in quotes.

It gets to "Solid bits" and I assume was never able to complete that test, so something doesn't seem right.

I was going to take out all the memory except for one 512 module and test that. Trouble is that the memory test can only be run on the protion of memory that's available so I was hoping for a test where I can point to a complete memory module that's not used at all and run a complete test on it.

BTW: I ran Drive Genius on the external drive - it checked all the blocks and found them all OK.
I don't have Disk Warrior, can DW do a better check?

· Premium Member
7,889 Posts
Discussion Starter · #7 ·
How long did you let it run - not reporting means the test did was not yet complete.
It ran all night - well from the time I went to bed until I got up, so that was about 7 hours. I was under the impression the test stopped at the point where it didn't say OK.

[/QUOTE] You can test one stick at a time tho two is better then swap positions.[/QUOTE]

Good idea.
That way I assume one stick gets fully tested.
Any suggestions how many cycles I need to run each test to get a valid result? Running it for 255 passes may take a long time.

· Premium Member
7,889 Posts
Discussion Starter · #9 ·
I'm suspecting the processor
You may well be right.

I read on another site that you can test the processor by running the chess game.
I did and it froze on two out of three tries.
Now to go back to the old 450 MHz processor and see what happens.

I'll run the memory test over night anyway- took out the two 256M chips and replaced them with another 512M I had kicking around. This one even said "G4" on it, but I don't know if the is the Mac G4 or some other G4 designation.

Many thanks for your insight and advice.

· Premium Member
7,889 Posts
Discussion Starter · #10 ·
Post I moved from clarkmueller
This is a bizarre problem, to say the least.

The answer to your question is... it... COULD be... But it makes no sense that it was a software problem if you weren't using that OS at the time. I suppose it could have been a corrupt file that was causing OS X to choke (e.g. during the permissions repair), but I would have thought that in such a case, SuperDuper wouldn't be able to back it up in the first place (SuperDuper spazzes out on teeny tiny issues, let alone big ones).

I would think it's more likely that there's a problem with your actual FireWire bus, or something of that nature, but that doesn't explain why the problem went away when you deleted this OS. My two best guesses would be that you had either a corrupt file on the drive, that for some reason was copied over to your backup, or that the FireWire bus or backup drive you used has a problem. But again... neither of those items explains why you were having problems before you backed up...

Alas, I would have loved to troubleshoot that one.

· Premium Member
7,889 Posts
Discussion Starter · #11 ·
Let me see...if I recap quickly.
About 2 1/2 ago I got kernel panics out of the blue, ie no hardware replaced, can't relate it to a download.
I backed up using Super Duper and eventually did an archive and install.
That seemed to fix the problem

Then yesterday, I got kernel panics as described in the first post of this thread - not only that, the mac ran quite slowly as well.
When I deleted the Super Duper back up from 2 1/2 weeks ago on my external FW drive, the mac speeded up noticable and the kernel panics stopped.
haven't had one since.
Checked all the drives with the OS disk utility - tey came out clean.
Did a surface scan on the drives - that came out clean as well.
Ran permissions on all the drives which I hadn't done for a long time - lots of updates there.
Then ran the chess game (supposedly to test the processor) - game froze two out of three tries.
Replaced 2 256 sticks with 1 512 stick and ran rember over night on all memory accessible (no applications running). In about 5 hours managed to get through 2 complete cycles with no errors and nothing stalled.

So now everything looks A OK - no sluggishness, no freezes.
Is there a proper way to test the CPU???

One other thing, I downloaded flash player 9 a couple of days go; that thing is a disaster. Not sure if it affected anything in the OS, but is there any way to get rid of it and go bach to flash player 7.

My two best guesses would be that you had either a corrupt file on the drive, that for some reason was copied over to your backup, or that the FireWire bus or backup drive you used has a problem. But again... neither of those items explains why you were having problems before you backed up...
Well, one of the backups was definitely corrupt. I backed that up in case the archise and install messed up since I have never ever done one - so if I lost any data doing it, I expected to be able to retrieve it from the corrupt back up (where the OS was corrupt, noy t the data).
So far nothing points to a problem with he back up drive or the FW bus. That drive is partitioed into three volumes and the other two volumes are fine.
I have still no clue what caused the original kernel panic and blue desktop, but I have never reinstalled OS X before and I have heard of others having to reinstall - so I assume over time (when did 10.4.3 come out) an OS can become corrupt.
One "feeling" I have is that 10.4.10 is not quite as good as 10.4.8 that I was on before, but there is 10.4.11 coming.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.