Canadian Mac Forums at ehMac banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Accidentally in console. . . help!

I accidentally held down the wrong key on re-booting and now am in the console (Tiger). I don't know the i.d. nor password, so I keep going between the console and the admin login window. How do I get out of the console??? Help, please. I don't want to re-install the os if I can help it since there are programs on the computer that require install disks that I no longer have. If you can point me in the direction I should go, I'd be most grateful.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
I am running Tiger on a G4 and accidentally held down the wrong key on reboot. I don't know the id or password for the console so now I cannot do anything except go back and forth between the console and admin login window. Is there a way out of this without re-installing the system?
 

·
Registered
Joined
·
347 Posts
Have you tried restarting? It sounds like you held down command-S, putting you into single user (UNIX) mode.
 

·
Tritium Glow
Joined
·
7,141 Posts
I'm assuming you're in verbose-mode. Try typing "mac-boot." No quotations or period.
I think you're thinking of Open Firmware.

Verbose mode is a visual version of the BSD boot process which ends in the GUI.

Yes, CBCer could be in OF or Console or Single User mode...not sure which.

To boot into Console, you have to use the login window, so that fits, but CBCer said that there was a key combination used, so it could be single user mode.

If in Console type "logout" or "exit"

If in Single User type "reboot"

EDIT: Well, it can't be Console. Just tried to login and it's no longer supported in Tiger according to the message I got. It just booted me back to the login window. Must have been one of the security updates.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Console woes

I've tried re-booting (many times) and typing ">exit" but without success. I think I'm in console since it says it at the top of the black screen. I also remember the word "Darwin" is at the top (sorry, I'm hours away from home at the present, and can't tell you exactly what is on the screen). I got into this mess by holding down the "option" key when re-booting. My os is 10.4.9, if that helps any.
 

·
Tritium Glow
Joined
·
7,141 Posts
Well, apparently you are in Console. But I don't know how you accomplished that with the option key...

Your regular login (the shortname+pswd) should work. Once you're in, type 'exit' or 'logout' which will launch the GUI and present you with the regular login window.

If that fails or you use autologin and no longer remember your pswd, there is a way to reset the password using the original install disc.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Ok. . . sounds as though I'm stuck. I don't know my id or password (except the admin id and password but they don't work in console). I was hoping there was an override so I could just get out of console but it appears I need to login first in order to get out of it. As to having disks, I'm not sure I have them. Lucky me. Anyone want a G4? Just pay for shipping and it's yours free. . . no, I'm kidding. I don't give up that easily.
 
G

·
If you're in the console and it's giving you a login prompt there's a problem with files on the machine. If it was single user mode you would not have a login prompt.

I'd say it's time to boot the machine from the install media (DVD?) and run disk utility on it (available from a menu in the installer screen) . If that doesn't solve your problem then do an archive and install and you should be back in business.

Lastly the admin id and password should work in the console, make sure you use the "short name" to login there -- not that it will get you anywhere in this situation except a working console ;)
 
G

·
Also just to note ... if you held down the option key at startup you should have been prompted to pick which drive to boot from. Is it possible that someone had installed a plain install of Darwin on this machine (as well as regular OSX) and you are booting into that? If your admin login is not working it could be that you're booted into another OS version on that machine ;)

Try this: hold down the option key when you restart, it should give you a graphical choice of disks to select to boot from. If there is more than one option try booting into one and then the other if required.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
I'll try these actions when I get back home, and if they work, you can bet I'll be back to say "thank you." I appreciate everyone's comments and knowledge. . . they all help me understand Mac's better (trust me, I don't know much :)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
Thanks (Thesus, The Doug, Vexel, kps, and mquertin) to all who responded!! I ended up re-installing the os BUT I Learned More Than I Knew Before you all helped. And everything worked out except I lost some secondary data that I'll need to input.

It may sound corny but . . .we sincerely appreciate you!
 
1 - 13 of 13 Posts
Top