Canadian Mac Forums at ehMac banner
tenfourfox
1-1 of 1 Results
  1. Anything Mac
    FireFox 4 requires an Intel processor and 10.5. The same fellow who is working on Classilla has taken the code and reworked it for 10.4 and G3/4/5 processors. It is running very nicely on my PB 12" 1.5 Ghz G4. Go to: TenFourFox: A fork of Mozilla Firefox 4 for the Power Macintosh and Mac OS...
1-1 of 1 Results
Top