ehMac.ca - View Profile: Silver Back
Facebook
Twitter
YouTube
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Advertise


Silver Back Silver Back is offline

Full Citizen

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. monokitty
    Yes, it's entirely possible the Left I/O Board (official name) is the problem; a while ago now, I had a fellow technician find out on a similar MBP that the Left I/O Board was preventing the back light from functioning. Replaced the board, and viola. Of course, it's not a guaranteed diagnosis. You'll have to change the part to see if it's the problem. Has the inverter board been changed? That part is also often the problem when it comes to back lighting issues.
  2. monokitty

About Me

  • About Silver Back
    Location
    Ottawa
    Occupation
    Retired
    Mac I'm currently using:
    iMac 24", 17" PowerBook, 15" G4 iMac, 15" MacBook Pro

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Nov 15th, 2019 09:07 AM
  • Join Date: May 29th, 2005
  • Referrals: 0

All times are GMT -4. The time now is 03:21 AM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 1999 - 2012, ehMac.ca All rights reserved. ehMac is not affiliated with Apple Inc. Mac, iPod, iTunes, iPhone, Apple TV are trademarks of Apple Inc. Content Relevant URLs by vBSEO 3.6.0 RC 2

Tribe.ca: Urban living in Toronto!