Airport Printing Issue - ehMac.ca
Facebook
Twitter
YouTube
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Advertise


Reply
 
LinkBack Thread Tools Display Modes
Old Sep 11th, 2009, 07:56 AM   #1
Full Citizen
 
Join Date: Jun 2006
Location: The Hammer
Posts: 807
Airport Printing Issue

I didn't want to hijack the other Airport Issue thread, so i thought i would start a new one..

I picked up a used Gigabit Airport Extreme (Last Years model, non dual simul band). It works wonderfully, i love it! Haven't had an issue until just recently (i don't want to blame Snow Leopard.. but..)

History...

Ever since the moment I installed the Airport, i have had my little HP Laserjet P1005 printer attached to it. It's worked great! I have my Macbook, the wife's XP netbook, an XP desktop, even my XP Parallels all were working and printing flawlessly. I was shocked at just how well it worked. Absolutely nothing to setup on the macbook since at the time it was Tiger and i used to connect the USB to print (so i already had the drivers locally). On the one XP desktop i installed Bonjour to see how that went (worked great), and the other two i just manually created the IP ports using Windows XP Printer Wizard.. again flawless.

... Until, i installed Snow Leopard on the Macbook. Now before i get jumped on, i know the P1005 doesn't have drivers yet for SL. I am not questioning that. What i don't get is how/why the XP boxes are no longer printing, they just get an error when trying to print (event log says the device is busy), or the netbook will spool the job then delete it like its been sent successfully to the printer (I also realize some people are going to hit me with this isn't a Windows forum, take it else where, but keep reading, i do come back to Mac Hardware). The Airport works great in all other aspects. I can telnet to the Airpot on port 9100, so i don't think the port is locked, blocked, disabled.. just doesn't print.

Let me add, I have been in the IT business for a few years now. I am not new to networked printers, printing issues, etc.. Also I know that upgrading one device shouldn't affect another. The number of times over the years i have heard from my users "Ever since you did the upgrade...." or "Ever since that downtime on a SQL server my Outlook doesn't work"... Yes nothing to do with anything related. I digress..

Does the Airport Extreme unit cache drivers within its memory? Could somehow the upgraded Snow Leopard's non functioning drivers somehow be holding up the printing on the within the device? When the Airport Utility is run to control the Airport Extreme, does it somehow pass driver information or anything like that to the unit? I have tried removing the drivers and reinstalling on ALL devices. I have factory reset the Airport Extreme and configured it again (Once on SL, once on Windows XP).. still nadda. Just will not print..

Thoughts? (and sorry for the long post, i just want to give as much detail as possible)

BReligion
__________________
"Hell hath no fury, like a woman scorned for Sega. " - Brodie Bruce :: Mallrats ::
BReligion is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old Sep 11th, 2009, 02:38 PM   #2
Full Citizen
 
digitddog's Avatar
 
Join Date: Jul 2006
Location: Calgary
Posts: 635
My wife had similar problems printing through our Airport Express (same model as yours) using her Windows XP laptop. Bonjour for Windows seems to have solved the problem.
digitddog is offline   Reply With Quote
Old Sep 11th, 2009, 03:28 PM   #3
Honourable Citizen
 
Join Date: Jul 2008
Location: toronto
Posts: 1,079
~

i also wonder whether you might have to start from scratch... i.e. disconnect everything, remove the original installed printers, and then re-connect and re-install... fyi, on the apple forums most people seem to do well installing hp printers via their ip address even if the drivers haven't been updated yet (you can query the attached printer to get it's address). good luck!
mkolesa is offline   Reply With Quote
 
Old Sep 15th, 2009, 09:34 AM   #4
Full Citizen
 
Join Date: Jun 2006
Location: The Hammer
Posts: 807
Thanks for the replies.. Still no go.

I have un hooked everything, rebooted everything, followed some of the apple trouble shooting steps... re-installed all Windows drivers (with the latest from HP, still none available for SL).. re connected both, one via Bonjour and one just straight IP connection, even gone as far as putting the firmware back on the Airport Extreme to the previous 7.4.1 (no good printing) then re applying to 7.4.2 (still no good)..

Still striking me really odd.. I can telnet to the router port 9100, it accepts the connection.. When i try to print from an app on either XP box, the job appears then disapears as if its printed (but it doesn't).. BUT, when i try to pring a test page, i get a error Win32 Error (I will post the exact code when i get home) that basically says the device is busy.. really really wierd.

I think i am going to blow the dust off the iBook and see if i can get it booted and install the drivers for it. I know it was supported by HP at one point.

Ah well for now the wife will have to go downstairs with her notebook and plug in the Printer.. ce la vie, just burns me that the printer sharing was one of the reasons i broke down and bought the Airport Extreme heh
__________________
"Hell hath no fury, like a woman scorned for Sega. " - Brodie Bruce :: Mallrats ::
BReligion is offline   Reply With Quote
Old Sep 15th, 2009, 03:14 PM   #5
Full Citizen
 
digitddog's Avatar
 
Join Date: Jul 2006
Location: Calgary
Posts: 635
So you can print from XP when the printer is connected directly via USB, right?
When you try to print via the Airport Extreme, is the XP connected via Ethernet or Wi-Fi?

I take it you've run through this list of possible solutions:
Printer troubleshooting for AirPort Base Stations and Time Capsule

Last edited by digitddog; Sep 15th, 2009 at 03:17 PM. Reason: Missed a point
digitddog is offline   Reply With Quote
Old Sep 15th, 2009, 04:02 PM   #6
Full Citizen
 
Join Date: Jun 2006
Location: The Hammer
Posts: 807
Quote:
Originally Posted by digitddog View Post
So you can print from XP when the printer is connected directly via USB, right?
When you try to print via the Airport Extreme, is the XP connected via Ethernet or Wi-Fi?

I take it you've run through this list of possible solutions:
Printer troubleshooting for AirPort Base Stations and Time Capsule
Yes, they both print just fine when connected via USB.
One is directly connected via Ethernet (Dekstop), one is WIFI (Netbook). Same result..

And Yes that document has been gone over several times
__________________
"Hell hath no fury, like a woman scorned for Sega. " - Brodie Bruce :: Mallrats ::
BReligion is offline   Reply With Quote
Old Sep 15th, 2009, 04:07 PM   #7
Honourable Citizen
 
johnb1's Avatar
 
Join Date: Aug 2006
Posts: 1,129
for what it's worth

I saw in Software update a few days ago, updated drivers for HP and I think Canon printers
you may wanna try that

JB
johnb1 is offline   Reply With Quote
Old Sep 15th, 2009, 04:53 PM   #8
Full Citizen
 
digitddog's Avatar
 
Join Date: Jul 2006
Location: Calgary
Posts: 635
Hmm. So the problem certainly seems to be with the Airport. Any chance it could be funky USB port on the Airport? Got an external hard drive you could hook up to test it?
digitddog is offline   Reply With Quote
Old Sep 15th, 2009, 05:41 PM   #9
Full Citizen
 
Join Date: May 2009
Location: Ottawa
Posts: 354
Have you tried using different ports, e.g. 9101 or 9102? Not sure how SL would affect that, but I know setting up my HP printer through Airport on a Windows machine I had to fiddle around manually with the port number.
Manatus is offline   Reply With Quote
Old Sep 15th, 2009, 08:42 PM   #10
Full Citizen
 
Join Date: Jun 2006
Location: The Hammer
Posts: 807
Hello to all... and thanks for all the suggestions (Bad port on the AE, trying hard drive, different ports.. of which the answers are no, yes and yes)... BUT I HAVE FOUND A SOLUTION (that worked for me at least)!!!

Again, i have NO idea what sense this might make, but here goes..

I found a thread on another site that said someone got the P1005 working using OLD drivers (Pre 10.5, let alone 10.6)
HP P1000-1500 series (v.1.04) available at
http://driverscollection.com/?file_cid=399489231573f9b4ad62f5159c3

I thought what the hell what's it going to do, not work?
Downloaded the Drivers
Deleted the current printer on the Macbook
Reset the printing system
Installed the Drivers
Powered the Printer off and On
Tried to print a document from Word 2008.... SUCCESS!!
Very excited...
Sent another one.. SUCCESS AGAIN!

I thought i would take a look at my XP desktop..
Still no go.. Same wacky errors
Understanding that I had bastardized it trying all kinds of drivers, port configurations, Bonjour and whatever I decided to uninstall everything again...

As i was reinstalling and rebooting, i hollered to the wife to try printing form her Netbook (which i haven't touched, and still wouldn't print up until this point) and *poof* out came the print job. She's been printing like mad ever since!

I can't explain it, but their must be some correlation between the drivers/printing system on the Macbook and the Airport Extreme..

Just wanted to say thanks again to all!

BReligion
__________________
"Hell hath no fury, like a woman scorned for Sega. " - Brodie Bruce :: Mallrats ::
BReligion is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airport Extreme printing issues chasMac Anything Mac 1 Nov 21st, 2008 05:52 PM
My new printer hates my Airport since84 Anything Mac 8 Apr 30th, 2007 07:53 AM
10.4.9 ! Snapple Quaffer Anything Mac 7 Feb 6th, 2007 08:53 AM
InDesign CS printing type issue (resolved!!) simon Mac, iPhone, iPad and iPod Help & Troubleshooting 7 Dec 30th, 2003 03:42 PM
wireless printing over airport (h/w & s/w?) rollee Mac, iPhone, iPad and iPod Help & Troubleshooting 1 Nov 20th, 2003 05:37 AM


All times are GMT -4. The time now is 12:27 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 1999 - 2012, ehMac.ca All rights reserved. ehMac is not affiliated with Apple Inc. Mac, iPod, iTunes, iPhone, Apple TV are trademarks of Apple Inc. Content Relevant URLs by vBSEO 3.6.0 RC 2

Tribe.ca: Urban living in Toronto!