Can't get Griffin iMic Mike input to work - ehMac.ca
Facebook
Twitter
YouTube
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Advertise


Reply
 
LinkBack Thread Tools Display Modes
Old Mar 25th, 2014, 11:23 AM   #1
krs
Honourable Citizen
 
krs's Avatar
 
Join Date: Mar 2005
Location: Ontario and Quebec
Posts: 9,103
Can't get Griffin iMic Mike input to work

I have a set of Sennheiser headphones with a mike boom that I want to use with a Macini and Skype.

Tried plugging in the two mini plugs into the Mini but the Mike part didn't work.
I assume the Mini input is a line level input not a low level Mike input, so this won't work.

Had an iMic lying around - this model:
https://www.google.ca/imgres?imgurl=...tart=0&ndsp=30

Tried that but still couldn't get the Mike to work.

I set the inputs and outputs in sound preferences to the USB input/output - headphones work fine that way but the Mike still does not.
The little slide switch between the to ports on the iMic is to switch between line and mike input levels, but which is which?
There is no designation on the unit itself and the iMic manual I downloaded was no help.
I assume the slide switch for low level Mike input should be towards the Mike input.

Does anyone actually have the iMic working with a microphone input?
What could I be missing?

Last edited by krs; Mar 25th, 2014 at 11:42 AM.
krs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old Mar 25th, 2014, 01:19 PM   #2
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 13,936
I have the same iMic model, but I haven't tried it with 10.9, but that switch on those models is sort-of back asswards in that it should be in the opposite direction from the icon you want to use as an input.

I'll have to try it with a headphone w/ mic I have but it needs an adapter for its tiny input plug to fit and work properly, which I don't presently have.

EDIT:

What model is your Sennheiser headphones??

And what connections does it provide??
pm-r is offline   Reply With Quote
Old Mar 25th, 2014, 02:16 PM   #3
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 13,936
My mistake on the switch which isn't really an input selector switch as I implied and according to some old sites:

[quotes]

Mic/Line Level Switch:
The input jack accepts either line level devices (like CD players, tape decks, etc.) or a microphone. Input type is selected via the black switch between the two audio jacks on the front of the iMic. For microphones push the switch toward the speaker icon. For line level devices push the switch toward the microphone icon.


Also, one bit of information I discovered on my own several years ago. If the iMic is connected through a basic USB 1.1 hub, it outputs audio in mono. I don't know if this is a design feature due to bandwidth limitations, or a bug. There is a Griffin USB 1.1 hub that does not cause this to happen. Of course nowadays probably just about everything is a USB 2.0 hub, which also does not exhibit this problem. If you are connected through a hub, though, and your music sounds a little flat, it might be worth starting up "Audio Midi Setup" (or some other app.) to play with your balance, and make sure you're getting both channels.
Does anyone have a Griffin iMic, the original instructions, and a scanner? - iLounge Forums

Surprisingly, the iMic does have one minor puzzler for first-time users who neglect to read the instructions ó the switch to choose between mic- or line-level for the input. Itís not labeled, so you must remember which position is which. Flipping the switch away from the input jack is for mic-level, while flipping it towards the jack is the line-level. This seems a bit counterintuitive, but itís only minor.
http://schwarztech.net/reviews/griffinimic

[end quotes]

So maybe use the headphone jack in mini sound out jack and the microphone jack into the iMic jack and set the switch accordingly for whatever position works.
pm-r is offline   Reply With Quote
 
Old Mar 25th, 2014, 02:29 PM   #4
Full Citizen
 
ahMEmon's Avatar
 
Join Date: Sep 2005
Location: Ajax, Ontario
Posts: 233
Send a message via MSN to ahMEmon
Did you go to your Audio/Midi setup (in the Utilities Folder) and set the iMic as Mic input?
ahMEmon is offline   Reply With Quote
Old Mar 25th, 2014, 02:45 PM   #5
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 13,936
Shouldn't be any need to use the Audio/Midi setup and the microphone and iMic should be available in the System Prefs 'Sound' pane to select and set.

But then again I don't know what type of microphone connector and connection type the Sennheiser headphones they have are using. That may be the goof up and lack of workability.
pm-r is offline   Reply With Quote
Old Mar 25th, 2014, 08:46 PM   #6
Full Citizen
 
Kami's Avatar
 
Join Date: Jul 2002
Location: Delta, BC
Posts: 599
Does this help? From the Griffin support page

Griffin Technology

Quote:

I can't get my iMic to work with Skype. (MAC and PC)

MAC:
If you are using a headset mic then you first need to connect the mic and speaker cable into the IN and OUT ports on the iMic.
Toggle the iMic to MIC.
Go to your System Preferences/Sound Preferences. On both the INPUT and OUTPUT tabs, select iMic from the list of devices.
Open your SKYPE PREFERENCES and choose AUDIO.
Select the iMic as both the audio input and output. (The same applies if you are only using a computer desk mic with no headset. The difference is that you choose the BUILT IN AUDIO for the System Preferences/Sound and SKYPE OUTPUT)
Kami is offline   Reply With Quote
Old Mar 25th, 2014, 11:13 PM   #7
krs
Honourable Citizen
 
krs's Avatar
 
Join Date: Mar 2005
Location: Ontario and Quebec
Posts: 9,103
Thanks for all the feedback - much appreciated.

I had already done all that was suggested above.
The slide switch between the ports is ass backwards as far as I'm concerned, if anything it should be in the position next to the Mike port for the low level Mike input.
I just kept trying both settings every time I changed something.

As to the Sennheiser headphones, they stragely enough don't have a model number anywhere on the headphones themselves.
But the headset cable terminates in two Mini phone plugs that plug right into the iMic or the Mini directly.

I luckily had a cheap $5.- PC Mike that someone gave me and I hadn't thrown out.
I tried that with the iMic and it worked perfectly.
I then tried the Sennheiser Mike connection again and it suddenly worked!

But after a bit of testing, it quit again, so now I think the problem is just an intermittent in the Sennheiser Mike cable or where the cable attaches to the plug.
Looking at pictures of Sennheiser headsets, it's the PC-131 that I have:
Sennheiser PC 131 - Stereo Headset - Ideal for gaming, internet telephony, Skype ...

PS: EhMac Email notification doesn't work or I would have replied earlier

Last edited by krs; Mar 26th, 2014 at 11:32 PM.
krs is offline   Reply With Quote
Old Mar 25th, 2014, 11:24 PM   #8
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 13,936
Glad to hear it's almost working well.

And please add your comments to the thread about email notifications that went goofy some time ago and still is. Some notifications I've received are up to five days late - i.e. basically useless and annoying...

http://www.ehmac.ca/ehmac-help-desk/...on-emails.html
pm-r is offline   Reply With Quote
Old Mar 28th, 2014, 11:51 AM   #9
krs
Honourable Citizen
 
krs's Avatar
 
Join Date: Mar 2005
Location: Ontario and Quebec
Posts: 9,103
Hmmm.....

Now I get the opposite - an email notification but no post on ehMac

Is it possible for a user (ie not admin) to delete a post on ehMac completely?

The post supposedly was:
Quote:
I have the same iMic model, but I haven't tried it with 10.9, but that switch on those models is sort-of back as swards in that it should be in the opposite direction from the icon you want to use as an input.

I'll have to try it with a headphone w/ mic I have but it needs an adapter for its tiny input plug to fit and work properly, which I don't presently have.
krs is offline   Reply With Quote
Old Mar 28th, 2014, 04:55 PM   #10
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 13,936
I haven't and I'm not authorized enough to completely remove my post which I see is still showing if that's what you are referring to.

PS: See my recent post on notifications I sent today at:
http://www.ehmac.ca/ehmac-help-desk/...on-emails.html

Last edited by pm-r; Mar 28th, 2014 at 05:09 PM.
pm-r is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
You want to drive to work? Then be prepared to walk. MACenstein'sMonster Everything Else, eh! 9 Dec 4th, 2010 09:46 AM
Audio cassettes to MP3 mrjimmy Mac, iPhone, iPad and iPod Help & Troubleshooting 24 Mar 6th, 2008 07:59 AM
Mike Baldwin dead! Ottawaman Everything Else, eh! 20 Jan 1st, 2007 08:37 PM
iMic & Mac OS 9, will it work? BIGBERTHA Mac, iPhone, iPad and iPod Help & Troubleshooting 1 Jul 14th, 2006 02:12 PM
web work with a mac? acc30 Anything Mac 14 Jun 23rd, 2006 08:03 AM


All times are GMT -4. The time now is 04:56 AM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 1999 - 2012, ehMac.ca All rights reserved. ehMac is not affiliated with Apple Inc. Mac, iPod, iTunes, iPhone, Apple TV are trademarks of Apple Inc. Content Relevant URLs by vBSEO 3.6.0 RC 2

Tribe.ca: Urban living in Toronto!