: Annoying iPhone 4 wifi issue.


daniels
Sep 28th, 2010, 08:07 PM
Wifi works fine on my mbp, iphone 4 connects to it but doesn't access the internet. I did a complete reset on the iphone 4 twice and it works fine for one day then the next day when i'm back from school it does the same thing. I also connect to the the wifi at school with no issues. I have to do a network reset every time to fix the problem but its back everyday. I'm sure it not the router because i also asked telus about it and they sent me another modem and its the same problem on this one. It was all working fine before the 4.1 update. What should i do?

Elric
Sep 28th, 2010, 10:10 PM
Every time I've ever had a problem with wifi for my iPod, iPhone, iPad or MacBook (usually at coffee shops with open networks) it's always been the fault of the router.

That doesn't mean your iPhone isn't defective, but try resetting your router to default configuration and see if that helps. Then tweak each setting you need thereafter.

daniels
Sep 28th, 2010, 10:25 PM
did it more then 10 times with the telus reps.

Joker Eh
Sep 29th, 2010, 06:59 AM
Check into the specs of the router, from iPhone website 802.11b/g/n Wi-Fi (802.11n 2.4GHz only)

daniels
Sep 29th, 2010, 10:47 AM
I'll try that when I get back home.

daniels
Sep 29th, 2010, 08:08 PM
it only has 802.11b
802.11b/g
and 802.11g

Joker Eh
Sep 30th, 2010, 09:59 AM
All I know is here at work the router is an old on DLINK DIR-624 2.4GHZ and it on has I think b/g, no "n", and I have problems here using the iphone 4 here on wifi, but never had problem is my 3g. All other routers I have connected to have the "n" and I have no problems with my iphone 4. So I would pony up and get a new router.

PhotoJim
Sep 30th, 2010, 01:59 PM
My iPhone 4 works well on my Linksys WRT54G 802.11b/g router. (I have 802.11b disabled and only permit 802.11g connections, since I have no b-only devices; I'm not sure if that's significant.)

Elric
Sep 30th, 2010, 03:36 PM
I remember changing the channel from the default 11 or 1 to something less used, fixed my 3G's wifi connections....

daniels
Sep 30th, 2010, 06:57 PM
All I know is here at work the router is an old on DLINK DIR-624 2.4GHZ and it on has I think b/g, no "n", and I have problems here using the iphone 4 here on wifi, but never had problem is my 3g. All other routers I have connected to have the "n" and I have no problems with my iphone 4. So I would pony up and get a new router.

no thats not true, it even says on the website specs: Apple - iPhone 4 - Size, weight, battery life, and other specs (http://www.apple.com/iphone/specs.html) 802.11b/g/n Wi-Fi. Anyway it was working fine before the 4.1 update. I switch the router to G still not working

Joker Eh
Oct 1st, 2010, 07:18 AM
no thats not true, it even says on the website specs: Apple - iPhone 4 - Size, weight, battery life, and other specs (http://www.apple.com/iphone/specs.html) 802.11b/g/n Wi-Fi. Anyway it was working fine before the 4.1 update. I switch the router to G still not working

Sorry daniels, copy and paste from iphone website 802.11b/g/n Wi-Fi (802.11n 2.4GHz only)

notice the part I highlighted. I also swtiched the router to just G and it only worked part time. I never had this problem with my 3G phone. try a router that has 'n' and see what happends I bet you have no problems.

Elric
Oct 1st, 2010, 09:24 AM
I connect to 4 different routers in a given week, and none of them are n routers. 3 g and 1 b.
iPhone 4, iPod Touch, iPad-no problems what-so-ever.

daniels
Oct 1st, 2010, 08:50 PM
its working fine now, i don't how but its all fine now.

Joker Eh
Oct 3rd, 2010, 12:06 PM
so now I am even more confused whats is the difference, and you know you are right, i am at my girlfriends place and her router is not N and I have no problems.