: Help setting up Lexmark all-in-one with Macbook


joyanne
Apr 21st, 2010, 03:22 PM
We got a new Lexmark all-in-one series X5400 and it set up fine with my MBP but when I plugged it into my husband's Macbook it wouldn't work. I installed it from the same CD and it has it listed as a printer, but when he hits print, nothing happens. We have checked the print que and the job is there. Tried setting it up as a wireless with the AE but neither laptops could find it that way. It only works when plugged into my MBP. Any ideas on how to get it to work with the Macbook would be appreciated.

Joyanne

Chimpur
Apr 21st, 2010, 04:16 PM
Have you made sure it's selected as the default printer? Also, check for any error lights on the printer.

ldphoto
Apr 21st, 2010, 04:36 PM
What version of OSX do the MacBook and MacBook Pro have? 10.6 will automatically download drivers when needed, but any earlier version will not do it. Perhaps that's why it worked well on the MBP.

joyanne
Apr 21st, 2010, 05:38 PM
Actually, the MBP is on Tiger 10.4.11 and works with the printer, but the Macbook is on Snow Leopard 10.5.8 and that is the one we are having the challenge with. It is set as the default printer and it shows up as the only printer but it isn't printing from the Macbook. Any other ideas?

Joyanne

mkolesa
Apr 21st, 2010, 06:40 PM
snow leopard has it's own print drivers (your printer is in this supported list Mac OS X v10.6: Printer and scanner software (http://support.apple.com/kb/ht3669)) and you may have created a conflict by installing the lexmark software. can you try doing an uninstall of the lexmark software? if so, do that then restart the computer and try again.

also, when you try different connection methods, like plugging into your airport you'll need to delete the printer in the print/fax list and re-add it as a new printer since it'll be accessed differently than it would be if it was plugged in directly. so if you didn't do that, that may be the reason why you couldn't get it to work wirelessly.

but if it were me and i had an airport i'd go wireless, then you can both use it without wires (keeping in mind the scan function will only work when it's connected directly). turn the printer off, plug it into your airport, turn it on, then on the macbook go to system preferences > print & fax then click the '+' sign to add a new printer and make sure that the 'default' tab is selected... give it a moment or two and it will locate the printer connected to the airport. select it and then add it to the printer list.

mkolesa
Apr 21st, 2010, 06:43 PM
oops... just re-read and you're actually using leopard (not snow leopard as you said)... you may need to update your lexmark drivers using this driver update for leopard:

Lexmark Printer Driver 1.1 (http://support.apple.com/downloads/Lexmark_Printer_Driver_1_1)

joyanne
Apr 22nd, 2010, 08:51 AM
The problem seems to be that the computer won't print to the Lexmark. In the print & fax the printer is set up as the default and is id;e and ready. When I press print, the job is in the que but the printer doesn't print although it says it is printing. I would like to set it up as wireless but I figured that if it didn't work connected then it would be impossible to work it as wireless. What is the system numbers for snow leopard? My husband bought snow leopard and thought that was what was installed. Thanks for your ideas. If you have any more let me know.

mkolesa
Apr 22nd, 2010, 09:43 AM
leaopard is 10.5 and you said you're running 10.5.8... snow leopard is 10.6 and the latest update is 10.6.3

did you update the print driver using the leopard updater i linked?

the kind of print problem you're mentioning is usually caused by a disconnect in the printer communication. so even if it says idle in the print&fax window, the computer may still not be 'seeing' the printer. to reestablish the connection you can try several things... disconnect the printer usb and then re-connect it. turn the printer power off and then on, or delete the printer from the print list and re-add it. it could be any of these things or all of them. but if you're both going to be sharing the printer this could happen every time you switch it from one computer to the other which is why i suggested you do the wireless printing... that way the printer always stays connected.

joyanne
Apr 22nd, 2010, 10:33 AM
Thanks. I have done all the things you suggested, including plugging it into the AE. I will try again later when I get back and will let you know what is or isn't working . I'm sure it is probably something quite simple, but annoying!

Joyanne

mkolesa
Apr 22nd, 2010, 10:41 AM
sure thing, good luck!

broad
Apr 22nd, 2010, 11:26 AM
i can pretty much guarantee it wont work via the airport express. its a well known and documented issue that most lexmark printers dont work via airport

printer is recognized, you hit print, printer just hangs indefinitely. ive seen it happen with several different lexmark models

DBF
Apr 22nd, 2010, 06:19 PM
I had a problem with a Lexmark x4550 today (would not scan a document). Tried several things including reloading the software. No Luck. Went to the Lexmark website technical support and to their "Live Chat" (only available during office hours). With the help of "Kristine" she had me delete every Lexmark file in my library on my Mac Mini, restarted the computer and then reinstalled the driver. Worked for me.