: Apps don't work, jumps back to home screen


Dominator
Aug 25th, 2008, 08:33 AM
I'm sure its been discussed here, and apple has apparently announced they will have this issue fixed in there next release. I can't find it discussed here though. The problem of buying an app in itunes syncing and then none of your purchased apps working. They appear to begin and then crash back to the home scree. My question is, have you guys figured out a solution other than restore etc. What worked for me last time was I went to the app store on my phone, there was an update for one of my apps and after taking the update everything worked. This last time it didn't work though. Any solutions to this?

thanks

just found this thread discussing this problem, haven't read it completely though.

Apple - Support - Discussions - iPhone applications no longer work ... (http://discussions.apple.com/message.jspa?messageID=7842663)

chimo
Aug 25th, 2008, 09:39 AM
Have you tried re-booting the iPhone/Touch? I had that problem on my Touch and it went away after I did a cold boot.

mkolesa
Aug 25th, 2008, 11:48 AM
...this is a problem for some users and there's not much you can do except re-set the iphone... touch wood, i haven't experienced it! i did read that downloading apps to your desktop/laptop and then syncing them to the iphone seems to be a better way to go (rather than using the apps store on the iphone), so you may want to try removing the apps from the phone, re-downloading them to your computer (if you bought them once it should be a 'free' download), and then syncing the iphone.

andy_tok
Aug 25th, 2008, 01:46 PM
This is exactly the same thing happened to me last night. I hope apple will post a fix soon.

wilecoyote
Aug 25th, 2008, 03:01 PM
I've only had this problem once - with Zenbe. I just uninstalled it (selecting and holding until the red X appears, then deleting), and then re-installed it from the app store (it told me I already had this app and would get it again free, even though it was free in the first place!).

Anyway, after doing that simple procedure it all worked again in less than a minute or two.

andy_tok
Aug 25th, 2008, 03:59 PM
Thanks, that helps. I uninstalled and reinstalled Palringo (the last app i downloaded), then everything turns out fine.

Dominator
Aug 25th, 2008, 05:51 PM
i've spent the better part of the day trying to get my apps to work without success. I've followed some of the different instructions in the apple thread, including doing a 2.5 hour restore, no freaking luck. Oh well almost out of time before going on vacation, hope it doesn't rain.

dfan
Aug 25th, 2008, 06:48 PM
What I found works is to just "power off" the iPhone and turn it back on and all the Apps works. Just hold the sleep button until the red power off slider appears. Turn if off and wait a second and turn it back on and the apps work.

I did not have to "restore" or "reset" my iPhone.

Compypaul
Aug 25th, 2008, 09:40 PM
I suffered through this the other day as well, but after I logged into the App Store to download a free game, all my installed apps worked again. It's certainly worth a try.