: Apple TV not Syncing

John Pryor
Aug 21st, 2008, 11:47 AM
My ATV appears in iTunes but when I try and sync it says I need to check that port 3689 is open. The ATV still works on the TV. The ATV is connected to the TC by ethernet cable and the Mac is connected by wifi. HELP:eek:

Aug 21st, 2008, 01:05 PM
i don't know anything about ports, but i assume appletv preferences has a connection setting so I was check that for the port #?

Aug 21st, 2008, 01:15 PM
Do you have the firewall enabled on your Mac? If so, you'll need to open that port by enabling "iTunes Music Sharing" in the firewall settings. (in the Sharing prefpane in System Preferences)

Apple TV: Data does not sync or stream after entering passcode (http://support.apple.com/kb/TS1447?locale=en_CA)

John Pryor
Aug 21st, 2008, 02:32 PM
I had already tried this link. It does not work for Leopard as the firewall settings are set up different then this article assumes.

Aug 21st, 2008, 10:26 PM
For Leopard, go to System Preferences -> Security -> Firewall and click "Allow all incoming connections", at least just to see if it's the firewall causing the problem.

You can use Network Utility on your Mac (in your Applications folder) to check if that port is open. Click the Port Scan tab, enter "localhost" for the address, check the "Only test ports between" checkbox and enter "3689" in both fields. Click the Scan button and it should display:

Open TCP Port: 3689 daap

in the box below if that port is indeed open.