: Problems with Restart


DDKD726
Dec 18th, 2007, 10:32 PM
Whenever I restart the iMac it just stays on the white screen. I have to unplug it, wait 10 seconds then plug it back in and power on for the apple logo to pop up and then everything is fine! i've downloaded everything available from Software Update. Am I missing something?

VictorDTarsus
Dec 19th, 2007, 02:24 AM
No worries dude, I was told to do the same thing if I got completely grey screen at startup. As I recall, a power outage caused by a thunder storm a summer of 2006 messed up my power brick. I take it that the iMac power supply would be a brick as well?

DDKD726
Dec 19th, 2007, 09:03 AM
actually no, there is no power brick...

monokitty
Dec 19th, 2007, 12:46 PM
Try resetting the SMC and PRAM:

Intel-based iMac, Intel-based Mac mini: How to reset the System Management Controller (http://docs.info.apple.com/article.html?artnum=303446)

Resetting your Mac's PRAM and NVRAM (http://docs.info.apple.com/article.html?artnum=2238)

SMC resets will occasionally fix problems surrounding shutdown/restart and startup issues when any of those commands do not function properly. Failing that, there is the potential that there may be a software-related issue causing the problem you're experiencing.

DDKD726
Dec 19th, 2007, 05:45 PM
I think the SMC is what I end up doing every time I try to restart.

I tired the PRAM instructions but just got held up at the grey screen with nothing... so I reset the SMC again and it booted up just fine.
Back to square one.

monokitty
Dec 20th, 2007, 11:28 AM
Backup your data and attempt an Archive and Install of the OS. Failing that, your unit may have a hardware defect.