: HELP. I can not drag anything in my finder


zigzagry
Jan 26th, 2004, 12:19 AM
I have somehow lost the ability to drag items. Both on my desktop, and in windows.

I have tried logging in to other user accounts and nothing changes. Ive rebooted and shutdown many times. One time it did work again. But is seems like the problem is sticking now. I am unable to put anything onto a disc now unless i launch individual files and save them to disc

I have had this problem maybe 2 or 3 times in the past on my previous computer (hd was pulled and put into this one)

I have been getting a lot of crash logs upon logging in.

im using osx 10.2.8 on a dual 450

MACSPECTRUM
Jan 26th, 2004, 12:24 AM
have u run disk utility to repair permissions?
if no, run it now

also 10.2.8 is a pain
try panther (10.3) or go back to 10.2.6

zigzagry
Jan 26th, 2004, 12:40 AM
in disk utility, first aid I tried "repair disk permissions" for my startup disk.

half way through. my finder crashed and took me back to the loggin screen!? when i logged back in i had a kernel panic and had to restart. now half my desktop icons are missing. but the names are still there


Im going to try it again.

MACSPECTRUM
Jan 26th, 2004, 08:34 AM
i would re-install the operating system and stay with 10.2.6 or upgrade to 10.3
looks like some serious damage
if the mac is somewhat operable backup whatever you need or can

Script Kiddie
Jan 26th, 2004, 10:29 AM
Look at your crash log: your coreservice daemon crashed. I found this on The Net. Perhaps it will help you.


"I have discovered the cause in my case: 'coreservicesd' never starts, and this might happen if the file /var/run/StartupItems/coreserviced.run already exists. This is an empty placeholder file, which apparently (if coreservicesd crashes) never gets removed."

see this page (http://www.applelinks.com/articles/2003/10/20031022121646.shtml) and links therein.

[ January 26, 2004, 10:14 AM: Message edited by: Script Kiddie ]

zigzagry
Jan 26th, 2004, 01:28 PM
I can not verify permissions to my startup disk. Ive tried about 10 times now. It keeps, just stopping. The blue processing bar appears to be in motion but it just stops in its tracks. I have gotten as far as three quarters done before having to press stop.

here is the latest crash log. Ive been able to grab. I still cant move files but i was able to again after one of my crashes.

Date/Time: 2004-01-25 00:20:15 -0500
OS Version: 10.2.8 (Build 6R73)
Host: Philip-J-Frys-Computer.local.

Command: coreservicesd
PID: 342

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xef5beedd

Thread 0 Crashed:
#0 0x90236634 in CSStoreGetUnit
#1 0x9280ca0c in _CSDataMapGetHashForToken
#2 0x9280326c in _CSMapFindBucketForKey
#3 0x928037a8 in _CSMapGrow
#4 0x928039ac in CSMapSetValue
#5 0x9280cfb0 in CSDataMapAddRefForToken
#6 0x9280a17c in _LSInsertClaimMapRefForToken
#7 0x9280ab64 in _LSReceiveBundleRegistration
#8 0x92818178 in _LSReceiveRegistration
#9 0x00107c28 in _LS_server_Register
#10 0x001076b8 in _XRegister
#11 0x00107b54 in LSPlugin_server
#12 0x90245dd8 in __SKMultiDemux
#13 0x90031b24 in mach_msg_server
#14 0x000035a4 in 0x35a4
#15 0x00003a38 in 0x3a38
#16 0x00002d04 in 0x2d04
#17 0x00002b84 in 0x2b84

Thread 1:
#0 0x90073ba8 in mach_msg_trap
#1 0x90005ed0 in mach_msg
#2 0x901489f0 in __CFRunLoopRun
#3 0x90180f58 in CFRunLoopRunSpecific
#4 0x90148240 in CFRunLoopRun
#5 0x000037ec in 0x37ec
#6 0x90020c28 in _pthread_body

Thread 2:
#0 0x9003e9a8 in semaphore_wait_signal_trap
#1 0x9003e7c4 in _pthread_cond_wait
#2 0x90190c88 in DNSecondaryQueueGetRetainedNote
#3 0x90190d68 in DNTalkToClients
#4 0x90020c28 in _pthread_body

PPC Thread State:
srr0: 0x90236634 srr1: 0x0200f030 vrsave: 0x00000000
xer: 0x00000000 lr: 0x9280ca0c ctr: 0x90236610 mq: 0x00000000
r0: 0x00000000 r1: 0xbffff460 r2: 0x82004288 r3: 0xef5beee1
r4: 0x00000104 r5: 0xeeceeee1 r6: 0xbffff4a0 r7: 0xbffff568
r8: 0x00000000 r9: 0x008d0000 r10: 0x008c801c r11: 0xa2800240
r12: 0x90236610 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x000ff024 r17: 0xbffff790 r18: 0x00080a00 r19: 0x00080ad0
r20: 0x00000001 r21: 0x00080b30 r22: 0x00000000 r23: 0x001e7fdc
r24: 0x001e6000 r25: 0x00048910 r26: 0x000007f7 r27: 0xeeceeee1
r28: 0xbffff564 r29: 0x0004cd8c r30: 0xbffff568 r31: 0x9280a338

zigzagry
Jan 26th, 2004, 07:17 PM
Nothing has changed. I have tried deleting the the cache items that were suggested on the site. but no change. I tried finding the info on coreservicesd crash and while the trouble shooting help is posted, I must purchase an account to access it.

I would re install but i dont have the disks. i bought the comp. with OSX installed. Im in trouble, I have an exteremly heavy workload (design), and all work is done on this system. ill just keep searching.

zigzagry
Jan 26th, 2004, 08:04 PM
hhhmmmmm. I may have fixed the problem. I tried running these commands.

ps -axww | grep "coreservicesd" | grep -v grep

sudo -b /System/Library/CoreServices/coreservicesd -preload AEServer

nothing changed

I then used cocktail to delete all sytem and user caches and then sucessfully repaired permissions by using cocktail aswell.

again nothing changed.
...I restarted the computer
and everything went smooth. quick startup, no missing icons, am able to drag icons, and NO CRASH REPORT!

I think now is a good time to back up those last few things. I have lost my operating system before and I've backed up ever since.

thanks for the help and thanks to script kiddie. a link, on a link, from the link you sent me seems to have helped out big time. ....for now

MACSPECTRUM
Jan 26th, 2004, 08:18 PM
and don't forget to buy a copy of the Mac OS X

Betty Fooz
Jan 26th, 2004, 08:39 PM
It's 10.2.8. There was old thread about it before. I had the same problem just after I installed the update. I posted the problem on ehMac and found that a few other people had the same problem. I was forced into purchasing Panther a couple of months before scheduled, all fixed now though.

zigzagry
Jan 26th, 2004, 08:51 PM
i know what you re saying about 2.8. the same day that i got it was the first kernel panic i had ever seen. I told everyone at school with a mac "dont upgrade to 10.2.8" and here i am still suffering with it. Im an idiot.

Script Kiddie
Jan 26th, 2004, 10:02 PM
Glad to hear it zigzag. smile.gif
I guess you found the macosxhints article, i should have checked there 1st. Anyways, glad you got past this without having to re-install --which smacks of windows, blah!--