: support combo pack gone from Apple site?


mcoltezo
Aug 25th, 2013, 09:30 AM
I have a macbookpro with snow leopard and I have in the past downloaded the latest service packs/maintenance packs from Apple but now I don't see them on their site. Am i just not seeing them or are they discontinued?

I just want to clean things up and make sure it's in tiptop condition. I do use Snow Leopard Cache Cleaner that I downloaded a couple years ago (probably at the suggestion of someone here). Is this still good or should I update it?

Thanks for you help. My specs should show up below in my signature block.

John Clay
Aug 25th, 2013, 10:13 AM
Did you try searching?
Apple - Support - Downloads (http://support.apple.com/downloads/#combo%20updater)

mcoltezo
Aug 25th, 2013, 01:57 PM
Did you try searching?
Apple - Support - Downloads (http://support.apple.com/downloads/#combo%20updater)

Hi John,

I tried but didn't find this. I had gone to Apple Support and downloads and only found "featured downloads" when I looked. And, just now I tried again and found this: Apple - Support - Downloads (http://support.apple.com/downloads/#macbookpro) and not the featured ones! Go figure. (this link looks the same as yours, though in my draft of this note, but goes somewhere else)

Thanks for sharing the link above!

pm-r
Aug 25th, 2013, 02:23 PM
What's showing in your 'Software Update' pref pane under the 'Installed Software' tab by date?

PS: The reason the top java update is showing in this shot is because I had to re-download the Java update as the software update only one didn't work properly with my SL. Seems there's some sort of bug and Java apps won't run properly until it's re-downloaded and installed.

If you've got all the recent stuff you should be OK, and it should look something like this:

mcoltezo
Aug 26th, 2013, 09:19 PM
What's showing in your 'Software Update' pref pane under the 'Installed Software' tab by date?

PS: The reason the top java update is showing in this shot is because I had to re-download the Java update as the software update only one didn't work properly with my SL. Seems there's some sort of bug and Java apps won't run properly until it's re-downloaded and installed.

If you've got all the recent stuff you should be OK, and it should look something like this:

Thanks for this list. I'll have a look and see.