Apple Mail Multiple Carriage Returns in Reply - ehMac.ca
Facebook
Twitter
YouTube
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Advertise


Reply
 
LinkBack Thread Tools Display Modes
Old Dec 16th, 2012, 05:49 PM   #1
Hotwiring another cessna
 
Finch's Avatar
 
Join Date: Aug 2003
Location: Toronto, ON
Posts: 389
Apple Mail Multiple Carriage Returns in Reply

Hello,

Long time Mac user looking to compete my migration to Apple Mail form Outlook. For the most part everything has ported aside from small teaks and tuning Mail is running. However, for the life of me I can't seem to correct the following:

When replying to a message there are 7-8 carriage returns between the original message and the new message above. Is this a bug or am I missing something with regards to correcting?

I've attached a screen capture in hopes of providing some visual.

Thanks,
Finch
Attached Images
File Type: jpg Screen Shot 2012-12-16 at 5.31.26 PM.jpg (21.0 KB, 6 views)
Finch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old Dec 17th, 2012, 12:29 AM   #2
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 14,037
Does this happen with ALL replied to emails?

And you didn't mention what method you used to migrate your Outlook email to Mail, and personally I find that Apple's Mail option is not always the best.

It's pretty easy to select and delete such extra space when replying and have you checked your Mail > preferences > accounts > composing tab etc. settings? Maybe something in there that's causing the problem?

Or, maybe this old fix still works:
Hawk Wings » Blog Archive » Apple Mail: “Hacking” the reply string

If none of those work for you and you want things to 'just work normally', then maybe archive and save the 'goofy' Mail account somewhere, then delete the goofy Mail account and start over by creating a new Mail account. Even if that's a bit of a drastic solution for just getting rid of some extra line feeds with some or any email replies.

Edit: Are you sure the sender of such emails haven't just added some extra line feeds to those emails?

Using TextEdit, or TextWrangler should show if any extra line feeds/carriage returns had been added to their original email that Mail would recognize and respect.

Last edited by pm-r; Dec 17th, 2012 at 12:54 AM.
pm-r is online now   Reply With Quote
Old Dec 17th, 2012, 02:07 AM   #3
Full Citizen
 
Ravindra Mohabeer's Avatar
 
Join Date: Oct 2003
Location: THE island
Posts: 360
Do you have your 'signature' set up to say 'Regards, Shawn' or do you type that each time?

If it's an automatic signature it's possible that there are some returns after the words that you might not see in the signature file (or there might simply be a 'put signature above replies' that is empty but still leaves a space - you could check the signatures option and see, just in case).

Weird otherwise.
Ravindra Mohabeer is offline   Reply With Quote
 
Old Dec 17th, 2012, 02:22 AM   #4
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 14,037
Quote:
Originally Posted by Ravindra Mohabeer View Post
Do you have your 'signature' set up to say 'Regards, Shawn' or do you type that each time?

If it's an automatic signature it's possible that there are some returns after the words that you might not see in the signature file (or there might simply be a 'put signature above replies' that is empty but still leaves a space - you could check the signatures option and see, just in case).

Weird otherwise.
That sure makes sense and a possible cause Ravindra Mohabeer.

Look for and check the possible simple cause right???
pm-r is online now   Reply With Quote
Old Dec 21st, 2012, 06:36 PM   #5
Hotwiring another cessna
 
Finch's Avatar
 
Join Date: Aug 2003
Location: Toronto, ON
Posts: 389
Thanks for the responses, older messages were ported from Outlook for Mac, everything else is populating based upon my current IMAP configuration. Indeed the first thing I did check was the signature file, no extra "white spaces" or carriage returns for that matter. To date it happens with each reply which is odd and becoming a pain.
__________________
The Photorialist | www.photorialist.com | MBP 15' | Canon Bodies | L, USM Lenses
Finch is offline   Reply With Quote
Old Dec 21st, 2012, 10:13 PM   #6
Honourable Citizen
 
pm-r's Avatar
 
Join Date: May 2009
Location: Brentwood Bay BC
Posts: 14,037
Well with any attempts to get rid of the problem if it were me, I'd remove any signatures, restart Mail and do some tests, and start over and see if things don't improve.

There's also a slight chance that you might have some obscure Mail 'Rule' that's causing the problem, or maybe the method you're using to add any signature.

No 'bug' in Mail for your problem, but some setting or preference or method that you're using that's causing your problem. All you need to do is eliminate all you can, test, and try again with new settings and signature(s).
pm-r is online now   Reply With Quote
Reply

Tags
apple mail, email, mail, mail.app

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heads up Mail search/Spotlight mail search problem MacDoc Anything Mac 21 Apr 17th, 2008 10:38 AM


All times are GMT -4. The time now is 11:12 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 1999 - 2012, ehMac.ca All rights reserved. ehMac is not affiliated with Apple Inc. Mac, iPod, iTunes, iPhone, Apple TV are trademarks of Apple Inc. Content Relevant URLs by vBSEO 3.6.0 RC 2

Tribe.ca: Urban living in Toronto!