Rogers - Email settings PLS Help - ehMac.ca
Facebook
Twitter
YouTube
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read


Reply
 
LinkBack Thread Tools Display Modes
Old May 9th, 2007, 11:44 AM   #1
New Neighbour
 
Join Date: May 2007
Posts: 4
Unhappy Rogers - Email settings PLS Help

Has anyone gotten a Rogers e-mail account to work with Mac's mail program? I am Running OSX 10.4.9. I am having trouble downloading mail from the server.

I can send mail alright but can not receive new mail.

I have tried changing the port to 587 Rogers own recommended setting and to 993, 995, but still I am having connectivity problems. I am following all of the settings that are posted on the Rogers| Yahoo website.

Thanks

Zak
zhusain is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old May 9th, 2007, 11:54 AM   #2
Full Citizen
 
switch's Avatar
 
Join Date: Mar 2004
Location: Toronto
Posts: 215
Hi, Zak!

I never had to fiddle with any port settings.
Incoming Mail Server: pop.broadband.rogers.com
User Name:
Password:

Outgoing: smtp.broadband.rogers.com

In Server Setting, I set it to password and put in my info. Let me know if your outgoing mail server is correct. Hope that helps!

Switch
switch is offline   Reply With Quote
Old May 9th, 2007, 03:39 PM   #3
Full Citizen
 
Join Date: Sep 2003
Location: Keswick, Ontario
Posts: 133
I had a problem at one time and Rogers sent me some specific server addresses to use. I am not at home so I can't help you out with what they are but they did solve my problems.

Sorry, not much help but I am on the road on my windows machine. CAll them and they should be able to give them to you. If not I can post them on the weekend.

Gunner
Gunner is offline   Reply With Quote
Old May 9th, 2007, 04:00 PM   #4
Honourable Citizen
 
Heart's Avatar
 
Join Date: Jan 2001
Location: YKF
Posts: 3,310
Quote:
Originally Posted by switch View Post
Hi, Zak!

I never had to fiddle with any port settings.
Incoming Mail Server: pop.broadband.rogers.com
User Name:
Password:

Outgoing: smtp.broadband.rogers.com

In Server Setting, I set it to password and put in my info. Let me know if your outgoing mail server is correct. Hope that helps!

Switch
This is what mine says too.
Just a couple things to clarify and help you piece it all together.

Outgoing port is 25
and the next item (SSL) is unchecked.

-
An old trick is to erase your User Name and Password and re-enter them.
Yes, Yes, Yes.... I know they look right but do it anyway, just humor me.

Do the same with:
Incoming Mail Server: pop.broadband.rogers.com
Outgoing: smtp.broadband.rogers.com


.
Heart is offline   Reply With Quote
Old May 10th, 2007, 03:43 PM   #5
Vorlon Ambassador
 
Kosh's Avatar
 
Join Date: May 2002
Location: Ottawa
Posts: 5,272
You don't have to change port numbers. Here's the instructions I posted on MUGOO:

Open Mail.
Select Add Account... from File Menu
Select POP as the Account Type
Put an account description in Account Description (the email address is good)
Put your name in Full Name (your real name or what you want on your emails)
Put your email address in Email Address
Hit continue

Put pop.broadband.rogers.com in Incoming Mail Server
Put your user name in User Name (the part of your email address before the @Rogers.com)
Put your password in Password
Hit continue

(Mail will try to find the pop server)
Put smtp.broadband.rogers.com in Outgoing Mail Server
Click the Use Authentication box
Put in your User Name and Password again
Hit continue

(Mail will try to find the smtp server and then present a summary of the info you gave it)
Hit continue


You can also manage accounts by selecting Mail Menu, Preferences and selecting the Accounts icon.
__________________
-- Mac Pro Dual 3.0 Dual Core, 4GB RAM, 150GB Raptor HD, 500GB HD, Superdrive, Radeon X1900XT, Bluetooth, Airport Exteme, Logitech Z-5500 5.1 Speakers, 30" ACD
-- PowerMac G5 Dual 2.5, 2.5GB RAM, 160GB HD, Superdrive, Radeon X800XT, Bluetooth, Airport Extreme
-- Macbook Pro 2.53 15", 4GB, 320GB HD, SuperDrive, Bluetooth, Airport Extreme
Kosh is offline   Reply With Quote
Old Jul 17th, 2009, 08:34 PM   #6
New Neighbour
 
Join Date: Jul 2009
Posts: 6
rogers email settings

I have just the same problems,man its frustrating.
Got a new Mac Pro 17" yesterday.
Got every thing else working except mail.
I was on the phone for 4hrs today trying to sort this out.
Spoke to 3 people at Rogers and 2 different Apple techy's,no luck.
What the heck is up with this deal.
Checked all the relevant info,pop this smtp that,the rogers guy and the Apple techy told me ever thing was as it should be but still cant get mail to come in.
I can send mail but not receive.
Any other techy guys out there that may be able to help,would certainly appreciate it.

Failing this,is there another email program u reccomend that can still get mail from the rogers server????
Thanks for any help offered.
Speyladdie.
Speyladdie is offline   Reply With Quote
Old Jul 17th, 2009, 10:04 PM   #7
Honourable Citizen
 
chas_m's Avatar
 
Join Date: Dec 2007
Location: Victoria BC
Posts: 11,896
Send a message via AIM to chas_m
If it isn't working with Mac Mail, it won't work with any other program. Mac Mail is as standards-compliant as it gets.
chas_m is offline   Reply With Quote
Old Jul 17th, 2009, 11:56 PM   #8
Honourable Citizen
 
HowEver's Avatar
 
Join Date: Jan 2005
Location: GTEh
Posts: 15,332
Wow, this thread has nearly 12,000 views (almost all of them in 2007, of course).
__________________
Vintage iBooks for sale: all Indigo.

HowEver is offline   Reply With Quote
Old Jul 18th, 2009, 04:59 AM   #9
Honourable Citizen
 
chas_m's Avatar
 
Join Date: Dec 2007
Location: Victoria BC
Posts: 11,896
Send a message via AIM to chas_m
Quote:
Originally Posted by HowEver View Post
Wow, this thread has nearly 12,000 views (almost all of them in 2007, of course).
Doh!
chas_m is offline   Reply With Quote
Old Jul 20th, 2009, 09:20 PM   #10
New Neighbour
 
Join Date: Jul 2009
Posts: 6
Rogers email .

AMAZING!!!!!!!!!!!!!
My email is now working???????????????

After talking to several Rogers and Apple techy's who couldnt resolve the problem it is amazingly now working.
Dont ask me what happened,I dont have a clue.Unbeleivable eh!
Speyladdie
Speyladdie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rogers email problem Elemenopee Anything Mac 11 Sep 9th, 2006 05:49 PM
sending email from Mail 2 with rogers itaca Anything Mac 8 Sep 10th, 2005 02:06 PM
Rogers email help GrapeApe Mac, iPhone, iPad and iPod Help & Troubleshooting 3 Mar 17th, 2005 03:41 AM
can't send email with rogers high speed klx Mac, iPhone, iPad and iPod Help & Troubleshooting 2 Feb 28th, 2005 06:44 PM
Please check your settings if you use email notification ehMax Anything Mac 0 Dec 10th, 2003 09:12 PM


All times are GMT -4. The time now is 09:58 PM.



Copyright 1999 - 2012, ehMac.ca All rights reserved. ehMac is not affiliated with Apple Inc. Mac, iPod, iTunes, iPhone, Apple TV are trademarks of Apple Inc. Content Relevant URLs by vBSEO 3.6.0 RC 2

Tribe.ca: Urban living in Toronto!